Closed Bug 1042466 Opened 7 years ago Closed 7 years ago

logviewer: List of buildsteps is unusable in some screen/font sizes

Categories

(Tree Management :: Treeherder, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: glandium, Assigned: jfrench)

References

()

Details

Attachments

(2 files)

Attached image Screenshot
If the font is too large compared to the window width, the list of steps ends up below the properties list, and it ends up showing only one step, which makes it very hard to use. And the button for raw logs is just invisible.

See attached screenshot.
FWIW, the window width is such because it's exactly half of 1920, which is the horizontal resolution of my screen.
Priority: -- → P2
Blocks: 1043474
I'll have a look at this and see what I can do.
Assignee: nobody → tojonmz
Status: NEW → ASSIGNED
There are some interesting UI regressions that occur in the structured log attempting to remove the absolute and fixed css properties of lv-log-container and run-data to make them responsive to a narrower page flow. Correct location scrolling via scrollTo() and also loadMore() aren't evident, and related we lose the container specific scroll bar, among other issues. Still looking at it.
With Camd's help we made some more progress. All failure steps and most of the passed steps are navigating to the correct log position. I'm still trying to sort out infinite scroll in the log container (new chunks are not being triggered when hitting the boundary) and the first 2-3 passed step-links in log steps aren't scrolling to the correct point in the log - when the browser is narrow.
Turns out my approach was a dead end, and :camd stepped in and saved the day. I've merged his changes locally and although there is one minor issue (the lower 'loadMore' chunk not being triggered perfectly at the boundary) it seems pretty nice. I will probably squash and open a first PR for review.
I spoke too soon. A bunch more flow and clipping problems introduced with those changes.
I spoke with jeads on IRC and we decided we'll wait till camd is back next week for better context on his approach. If anyone wants to pursue it before that, just ping me.
Summary: Structured log viewer list of steps is unusable in some screen/font sizes → logviewer: List of buildsteps is unusable in some screen/font sizes
I spoke with camd on IRC and I'm going to push camd's work with some very minor tweaks and open a PR shortly for review. Successful steps on passed jobs will be clipped slightly at extremely narrow browser dimensions, but other than that all the functionality is there and it addresses the initial user problem.
Attached file treeherder-ui-PR#131
Please see the above PR for review and status.
Appears to be fixed and working correctly on dev. Marking fixed prior to push to stage/prod.

There are a couple of minor log scroll issues w.r.t. failed steps, but I don't think they are related to this change. I will open them as separate non-blockers if applicable.
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Looks good on dev thank you :-)
You need to log in before you can comment on or make changes to this bug.