Closed Bug 1042497 Opened 7 years ago Closed 7 years ago

Unable to find the proxy server in tab where proxy is set after it's opened

Categories

(Core :: Networking, defect)

33 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: raysatiro, Unassigned)

References

(Blocks 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20140722000501

Steps to reproduce:

In the latest Aurora I am not able to enable a proxy for current tabs.

gecko.mstone = 33.0a2
gecko.buildID = 20140722004002


Actual results:

Change proxy settings to no proxy.

Open a tab and go to https://bugzilla.mozilla.org/

Change HTTP and SSL proxy settings to a proxy. For example in this case I have a proxy listening on 127.0.0.1 port 8888.

In the same tab click reload. I get "Unable to find the proxy server".

If I open a new tab and go to the same website it works. It's only existing tabs that were initially opened without a proxy server that have the problem.


Expected results:

I should be able to change my proxy settings without breaking current tabs.
Version: 24 Branch → 33 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041511
reopened based on https://bugzilla.mozilla.org/show_bug.cgi?id=1041511#c42
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
Component: Untriaged → Networking
Product: Firefox → Core
I can reproduce the reported proxy problem on linux on the 7/22 nightly.  I cannot reproduce the problem on the 7/24 nightly on either linux or windows.  Make sure you are running the version you think you are.
the root cause patches in 354493 and 1041511 have been backed out - so this can be closed.
Status: REOPENED → RESOLVED
Closed: 7 years ago7 years ago
Resolution: --- → WONTFIX
(In reply to Marc Auslander from comment #3)
> I can reproduce the reported proxy problem on linux on the 7/22 nightly.  I
> cannot reproduce the problem on the 7/24 nightly on either linux or windows.
> Make sure you are running the version you think you are.

I just checked and you're right. Sorry about that. I've updated the other bug.
https://bugzilla.mozilla.org/show_bug.cgi?id=1041511#c45
Resolution: WONTFIX → INVALID
You need to log in before you can comment on or make changes to this bug.