<span> not contained by <p>

VERIFIED FIXED

Status

()

Core
HTML: Parser
P3
normal
VERIFIED FIXED
19 years ago
5 years ago

People

(Reporter: Christine Hoffman, Assigned: rickg)

Tracking

Trunk
All
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
Using 7/23 Apprunner on Win 95, Win NT, Win 98, Linux and Mac8.6 (7/22 build).

Open attached file in Apprunner. Paragraph has a 'display: block' value
assigned. Second sentence is within a <span> element tag.

Expected results: Second sentence (within a <span> tag) should not inherit the
'display: block' value from its parent <p> - it should continue inline.

Actual results: <span> appears to inherit the 'display: block' value as a block
box is generated.
(Reporter)

Comment 1

19 years ago
Created attachment 974 [details]
Test case to demonstrate problem

Updated

19 years ago
Assignee: peterl → rickg
Component: Style System → Parser
Summary: display: block is being inherited from parent → <span> not contained by <p>

Comment 2

19 years ago
Parser/DTD issue. The <span> is not being contained within the <p>.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 3

19 years ago
Fixed by last update.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

19 years ago
Using 7/30 Apprunner, verified bug fixed.

Updated

5 years ago
Duplicate of this bug: 808283
You need to log in before you can comment on or make changes to this bug.