Decimal separator should be localized

RESOLVED FIXED in Firefox 36

Status

()

defect
--
minor
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nicolas.barbulesco, Assigned: rstrong)

Tracking

unspecified
Firefox 36
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments, 1 obsolete attachment)

I have Win 7. 
I go to www.getfirefox.com 
The site invites me to download the new Firefox 31. 
I click "Systèmes et langues". 
I choose Firefox 31 in french for Windows. 
... 
I launch the downloaded installer. 
... 
I encounter this screen : 
see screen photo to come Firefox-31-installer.png 

The dialog is in french. But the disk spaces are written incorrectly : 

"71.0Mo" 
"386.7Go"

The correct writings expected instead are : 

"71,0 Mo" 
"389,7 Go" 
With the comma as decimal separator, and with a non-breaking space between the number and the unit.

Thank you for correcting this, and keep up the good work !

Nicolas
(In reply to Nicolas Barbulesco from comment #0)

> The correct writings expected instead are : 
> 
> "71,0 Mo" 
> "389,7 Go" 

Sorry for the typo ; "386,7 Go", of course.
Could you check the express installer's options page in French as well and provide a screenshot?
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #2)

> Could you check the express installer's options page in French as well and
> provide a screenshot?

What is "the express installer's options page" ? 
What steps would I do to display it ?
Flags: needinfo?(robert.strong.bugs)
Did the main page of http://getfirefox.com not offer you a French version of Firefox?

You can download it here
https://www.mozilla.org/en-US/products/download.html?product=firefox-stub&os=win&lang=fr

The first page will have a button in the lower left to display the Options page. Please take a screenshot and attach it to this bug. Thanks
Flags: needinfo?(robert.strong.bugs) → needinfo?(nicolas.barbulesco)
Flags: needinfo?(nicolas.barbulesco)
(In reply to Robert Strong [:rstrong] (use needinfo to contact me) from comment #4)

> Did the main page of http://getfirefox.com not offer you a French version of
> Firefox?
> 
> You can download it here
> https://www.mozilla.org/en-US/products/download.html?product=firefox-
> stub&os=win&lang=fr
> 
> The first page will have a button in the lower left to display the Options
> page. Please take a screenshot and attach it to this bug. Thanks

Robert, you will find the attached screen photo : Firefox-31-installer-options.png 

Here we have half of the problem. The dialog in french has the spaces, but uses "." as decimal separator.
Please select the installer or stub installer you downloaded, select properties for the file, take a screenshot of the General tab, and attach it to this bug. Thanks!
Robert, you like screen photos. :-) 
Here is coming the screen photo Firefox-31-installers-properties.png, with : 
 - At the left, the properties of the installer of my comment 0 
 - At the right, the properties of the installer of your comment 4
Summary: In the Firefox installer, the disk spaces are incorrectly written → Decimal separator is determined by the OS's locale and not the locale of the installer
The problem is not only the decimal separator. The space is missing too.
Summary: Decimal separator is determined by the OS's locale and not the locale of the installer → Decimal separator is determined by the OS's locale and not the locale of the installer, and the space is missing before the unit
(In reply to Nicolas Barbulesco from comment #10)
> The problem is not only the decimal separator. The space is missing too.
In the full installer. That will be fixed when the full installer is changed to use the stub installer ui.
Summary: Decimal separator is determined by the OS's locale and not the locale of the installer, and the space is missing before the unit → Decimal separator is determined by the OS's locale and not the locale of the installer, and the space is missing before the unit in the full installer
I'm going to make this bug about the separator issue since the second issue will be fixed by bug 1004403.
Assignee: nobody → robert.strong.bugs
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Summary: Decimal separator is determined by the OS's locale and not the locale of the installer, and the space is missing before the unit in the full installer → Decimal separator should be localized
Posted patch patch rev1 (obsolete) — Splinter Review
Attachment #8524986 - Flags: review?(netzen)
Comment on attachment 8524986 [details] [diff] [review]
patch rev1

Review of attachment 8524986 [details] [diff] [review]:
-----------------------------------------------------------------

Unless you have an objection, I think the best way to do this is just by using the system configured locale:
http://nsis.sourceforge.net/Get_the_system_decimal_delimiter
In app we do the same.
Attachment #8524986 - Flags: review?(netzen)
(In reply to Brian R. Bondy [:bbondy] from comment #14)
> Comment on attachment 8524986 [details] [diff] [review]
> patch rev1
> 
> Review of attachment 8524986 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> Unless you have an objection, I think the best way to do this is just by
> using the system configured locale:
> http://nsis.sourceforge.net/Get_the_system_decimal_delimiter
> In app we do the same.
We don't use the current system locale and since the text is in another locale I think it would be best to use the locale's decimal separator since it is simple enough.
Comment on attachment 8524986 [details] [diff] [review]
patch rev1

What reason(s) can you think of as to why should it use the system's decimal separator besides that is what we do in app?
Attachment #8524986 - Flags: review?(netzen)
Comment on attachment 8524986 [details] [diff] [review]
patch rev1

Review of attachment 8524986 [details] [diff] [review]:
-----------------------------------------------------------------

Reasons why is just because I don't really consider it part of the language itself, and more of a region type thing.
And a typical user who has this set, is used to seeing the separators in the way that it is displayed everywhere on their computer.

That being said, I'm not strongly against it so it's ok.
Attachment #8524986 - Flags: review?(netzen) → review+
Comment on attachment 8524986 [details] [diff] [review]
patch rev1

I think it might as well not have decimal places since these are all just estimations anyway.
Attachment #8524986 - Attachment is obsolete: true
Attachment #8525762 - Flags: review?(netzen) → review+
https://hg.mozilla.org/mozilla-central/rev/94e9fc62355f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.