If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Network monitor does not show full URI rendering it uninformative for RESTful style sites

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED WORKSFORME
3 years ago
2 months ago

People

(Reporter: andrew, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Use network monitor on site using RESTful style API


Actual results:

Network monitor shows "File" which results in just query string. Example  just showing the cache busting for a request "_=1406127229875"


Expected results:

Expect ability to show URI instead  of "File".   

Useful:
     /rest/channel/NjE6MTY6MQ==/?_=1406127229875

Annoying causing me to switch to chrome for development
     /?_=1406127229875

Updated

3 years ago
Component: Untriaged → Developer Tools: Netmonitor

Comment 1

3 years ago
+1

In this scenario, Firebug is much better, and shows the full URL on hover.

* The "File" header should be renamed to "URI" or "Resource"
* Also, there should be an option to view the full url

Comment 2

3 years ago
I agree with both points from comment 1 and the Firebug comment is something that bothers me: it seems that by internalizing the Developer Tools into FF, Mozilla is duplicating the years of bug fixes that have gone into Firebug. Is there a place where I can read about this duplication of effort?
This was reported via the uservoice channel: 

https://ffdevtools.uservoice.com/forums/246087-firefox-developer-tools-ideas/suggestions/7160040-network-panel-show-the-complete-path-of-each-requ

"In the network panel, there is a column that shows the file retrieved in each request, but in order to see the paths you need to click on the requests one by one. This is especially annoying with sites that have many requests the differ only in the path, and then they all look the same in the requests table. Instead of a column with the file name, the table should have a column with the complete path of each request."

..adding this to the papercuts bug.

Jordan: this feels like a pretty shallow one - good first bug?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(jsantell)
There are several bugs that all revolve around this. There are a few approaches to this:

* Add a new column for the full path (we are running out of room)
* Display it underneath the filename (like Chrome)

Ultimately, I'd like the network table view to be configurable (select which columns, size, etc), which would fix this by adding a column. James and I are checking out network monitor this month so hopefully we can figure out how to get additional information like this in there.

I'd be hesistant to have this as a good first bug for the reasons of a giant refactor incoming
Flags: needinfo?(jsantell)
(In reply to Jordan Santell [:jsantell] [@jsantell] from comment #4)
> There are several bugs that all revolve around this. There are a few
> approaches to this:
> 
> * Add a new column for the full path (we are running out of room)
> * Display it underneath the filename (like Chrome)

Chrome has a tooltip that shows the full uri ( http://note.io/1M41Bfi ), we show the filename / query string ( http://note.io/1AS2hRb )

I thought this could be GFB because I'm really just asking for the domain to be added into the filename tooltip. If I had that ( and if the columns were configurable ) I'd probable remove the 'domain' column.

Comment 6

3 years ago
(In reply to Jeff Griffiths (:canuckistani) from comment #3)
> This was reported via the uservoice channel: 
> 
> https://ffdevtools.uservoice.com/forums/246087-firefox-developer-tools-ideas/
> suggestions/7160040-network-panel-show-the-complete-path-of-each-requ
> 
> "In the network panel, there is a column that shows the file retrieved in
> each request, but in order to see the paths you need to click on the
> requests one by one. This is especially annoying with sites that have many
> requests the differ only in the path, and then they all look the same in the
> requests table. Instead of a column with the file name, the table should
> have a column with the complete path of each request."
> 
> ..adding this to the papercuts bug.
> 
> Jordan: this feels like a pretty shallow one - good first bug?

Jeff: Yes, this is a "papercut" bug (btw, nice name). The problem I see in dev tools right now is that there are a lot of paper cuts in the module.

https://github.com/firebug/firebug.next/issues/326

It has become increasingly painful to work in dev told for even simple things like adding styles for pseudo selectors etc. The only thing this does is that it makes me want to crawl on all fours to Chrome... Have resisted till now, probably will keep using dev tools, only because it's faster while running, although not even having some options like seeing contents of web sockets does cause immense pain 

Comment 7

7 months ago
Instead of full URI, We show filename and query params in `file` column now. Hovering on name column will show the full URI.

Close this issue now. If any missing we can file a new bug to track the new enhancement
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME

Comment 8

2 months ago
This is still an issue is it not? I don't see any way of showing the full URI in the listing.

I'm currently interacting with a REST API that results in requests similar to this:

/users/4f8f7a7e-037b-41aa-8bf8-f2ae494dfef4
/groups/54159ff3-a9cf-4cc8-a4f0-70bd8b77a2f1?include=users,roles,items
/users/fad49de7-22a5-4e39-a594-f75b1985df0c
/users/ab2f965e-2b2d-422a-ae90-4430477553be
/items/d8a3f4f6-6df1-46b3-af39-c008a46a2395
/attachment/f4a0f974-a652-4aea-bf64-02831e3765b6
/messages/1de5f5d7-87a1-48ea-9066-12b64abb6e2b
/messages/1695dd34-2e8f-4304-8bad-b5303109d6da
/notifications/9fc4680d-872d-4b37-bf64-47fc481d7ecd
/notifications/dd161bb5-de05-4390-b1b2-fc531a667ad0

As a result all I get in the network tab is a list of UUIDs without any clear way of being able to see which request relates to what resource:

4f8f7a7e-037b-41aa-8bf8-f2ae494dfef4
54159ff3-a9cf-4cc8-a4f0-70bd8b77a2f1?include=users,roles,items
fad49de7-22a5-4e39-a594-f75b1985df0c
ab2f965e-2b2d-422a-ae90-4430477553be
d8a3f4f6-6df1-46b3-af39-c008a46a2395
f4a0f974-a652-4aea-bf64-02831e3765b6
1de5f5d7-87a1-48ea-9066-12b64abb6e2b
1695dd34-2e8f-4304-8bad-b5303109d6da
9fc4680d-872d-4b37-bf64-47fc481d7ecd
dd161bb5-de05-4390-b1b2-fc531a667ad0

I end up having to click through them one by one which is rather slow. In the interest of speed I usually end my day in Chrome which does show the full path, can Firefox not have an option for something similar?
You need to log in before you can comment on or make changes to this bug.