Add a delete option for links on Most Visited. Right now mine are all hotspot login pages

RESOLVED DUPLICATE of bug 913457

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 913457
4 years ago
4 years ago

People

(Reporter: bugs, Unassigned)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
I rather like the idea of Most Visited, apart from the problem above.
I don't mind periodically deleting the hotspot pages, except that there appears to be no way to do this, which is odd since both Bookmarks and History on either side (and similar conceptually) have a delete option.

If I could delete the hotspot pages, I could also pin some of the other pages.
Another similar issue is pages of HN taking up multiple slots.  Being able to delete those would help too.

An option to permanently hide on Most Visited would entirely solve the problem, but is a bit convoluted, compared to simply enabling the functionality the other screens have.

Oh, also, is it just me, or is this Most Visited only showing pages from the device, not sync, unlike the history page?
(In reply to nemo from comment #0)
> I rather like the idea of Most Visited, apart from the problem above.
> I don't mind periodically deleting the hotspot pages, except that there
> appears to be no way to do this, which is odd since both Bookmarks and
> History on either side (and similar conceptually) have a delete option.

Bug 913457, fixed in Firefox 32.

> An option to permanently hide on Most Visited would entirely solve the
> problem, but is a bit convoluted, compared to simply enabling the
> functionality the other screens have.

We're aware that Top Sites doesn't work well for Sync users or some kinds of pages; see, e.g., Bug 934702.

But I think this specific request is Bug 1010266.

> Oh, also, is it just me, or is this Most Visited only showing pages from the
> device, not sync, unlike the history page?

It shows most frecent (frequency + recency) pages, including those from Sync.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 913457
You need to log in before you can comment on or make changes to this bug.