If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Employees should be able to vouch users

VERIFIED WONTFIX

Status

Participation Infrastructure
Phonebook
VERIFIED WONTFIX
3 years ago
3 years ago

People

(Reporter: rbillings, Unassigned)

Tracking

Details

(Whiteboard: [vouching rel. 1], URL)

(Reporter)

Description

3 years ago
Testing on stage, I do not see the ability to vouch for other users when viewing their profile.

1) log in as employee - confirm I have 4 auto-vouches
2) enter url for pending profile: https://mozillians.allizom.org/en-US/u/cerulean111/

expected: able to vouch for pending user
actual: no vouch button

* Tested on both FF30 & Chromie
This is by design. Users with 'can_vouch' can vouch users. Currently you need 3 vouches to get the can_vouch flag. Being an employee doesn't imply being able to vouch.
Blocks: 926644
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

3 years ago
I would think that employees are one of the primary sources of vouching. As an employee I shouldn't have to go find other people to vouch for my work in order to vouch for others- it's our job to be vouchers. This is not only annoying, it's going to greatly reduce the ability to get new contributors in the system- the ones who deserve to be there.
This is a valid point Rebecca. The main argument behind the current design is that not all employees automatically understand how community and vouching worksm just because they are employees. They have therefore to go through the same process contributors go to, to be allowed to invite others in. This is also to minimize separation between employees and non-employees. Once they get the can_vouch flag which is a matter of 10 minutes if you're active in community, you can go ahead and vouch.
OS: Mac OS X → All
Hardware: x86 → All
Bumping to verified WONTFIX .. the new vouch model works as defined/designed/expected.
Status: RESOLVED → VERIFIED
Resolution: INVALID → WONTFIX
You need to log in before you can comment on or make changes to this bug.