All users were logged out of Bugzilla on October 13th, 2018

Preferences 'OK' button does not close window unless a change has been made in the preferences

VERIFIED WORKSFORME

Status

VERIFIED WORKSFORME
17 years ago
14 years ago

People

(Reporter: TucsonTester2, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20011009
Netscape6/6.2 

Build ID 20011009
Summary:
Preferences 'OK' button does not close window unless a change has been made in
the preferences
Reproducible:
Always

Steps to Reproduce:
1.Open New Composer page
2.From the toolbar select 'Edit>Preferences'
3.Double-click on any of the options at the left to see you preference options
but do not change any of them
4.once done looking at preferences without changes anything click on the 'OK' button
5.Notice the page does not close.

Actual Results:
The page does not close with the'OK' button if you have not perforemd any
actions or changes inside the preference window.

Expected Results:
I expected the window to close with the 'OK ' button even though you did not
make any changes. The 'OK' button should tell the program that you are done
using that feature weather there was anything done or not should have nothing to
do with if the page closes or not.

Additional Information:
The work around (I'm sure it's obvious) is to click the X at the top right corner.

Comment 1

17 years ago
Sarah, do you see this behavior ?

Comment 2

17 years ago
Mozilla/5.0 (Macintosh; U; PPC; en-US; rv:0.9.4) Gecko/20010913

It works for me.  On this build/platform (Carbon build on Mac OS 9.2.1 
[yeah, I know, you're not supposed to do that]), there is no close box in the 
titlebar of the Preferences dialog.
this is also WFM using 2001.10.09.09-trunk bits on winNT.

perhaps this only occurs after a *specific* panel has been viewed. [there have
certainly been bugs like that in the past!] if you can repro this with a
particular panel, do reopen. however, marking wfm for the time being...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
marking verified...REOPEN if you definitely still see the problem.
we can't reproduce it..
Status: RESOLVED → VERIFIED

Comment 5

17 years ago
I am able to reproduce this on Win 2k using build 20011010 and Win 98 using
build 20011009.  One thing to note, is that in order for me to reproduce this
problem, I had to open enough categories on the left hand side to get the scroll
bar to appear.  And then the OK button quit working. 

I am reopening this bug.  
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

17 years ago
Don't see this on linux - but then, I don't see a scrollbar in the
left hand pane, even if the options are longer than the box. Hm,
should check that's logged.

Comment 7

17 years ago
Worksforme even with a scrollbar, Windows 2000, 10/16 NS 6.x build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → WORKSFORME

Comment 8

17 years ago
Verified.
Status: RESOLVED → VERIFIED

Comment 9

17 years ago
marking verified.

Comment 10

16 years ago
reassign bugs in case they are later reopened
Assignee: syd → composer
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.