Vouching does not announce that you've been demoted

VERIFIED DUPLICATE of bug 997422

Status

Participation Infrastructure
Phonebook
VERIFIED DUPLICATE of bug 997422
3 years ago
3 years ago

People

(Reporter: rbillings, Unassigned)

Tracking

Details

(Whiteboard: [vouching rel. 1])

(Reporter)

Description

3 years ago
Users who are able to vouch on production will no longer be able to do so with the new system- but they are not notified that they have been demoted. Users creating a new profile are presented with a message including a link to info. If you are going to change permissions for users there should be some message or announcement explaining what happened and why.
We have a communication plan which includes emails, announcements on the website and yammer, which will explain this and other changes on the website. This is bug 997422

If you find that is what's needed here please mark the bug as duplicate.
Blocks: 926644
OS: Mac OS X → All
Hardware: x86 → All
(Reporter)

Comment 2

3 years ago
I do not agree that the linked communication plan bug effectively notifies people that their permission to vouch has been removed- but I've commented on bug 997422.

I also think that emails and yammer notifications are not reliable ways to contact people, and that there should be a notice in the UI.
Where will be announcements(In reply to Rebecca Billings [:rbillings] from comment #2)
> I also think that emails and yammer notifications are not reliable ways to
> contact people, and that there should be a notice in the UI.

There will be announcements on the home page of each user.
Maybe :williamr has more to add to this?
Flags: needinfo?(williamr)
(Reporter)

Comment 5

3 years ago
Notifications on the home page would totally cover this- I just am not seeing it on staging.
Valid. You're not seeing it because it not there. The announcement on the website is something managed by williamr and has to be manually added/edited through the admin panel. No further code change is needed for this announcement.
I think the explanation will now be clear with the Account Status section on the Edit Profile view (see bug 1042904).

Per comment 6, there will also be an announcement on the mozillians.org homepage for signed-in users for several weeks.
Flags: needinfo?(williamr)
Based on comment 5 and comment 7, I am marking this as a duplicate. Thanks Rebecca!
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997422
Bumping to verified duplicate -- I hope/think your concerns were met when bug 997422 landed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.