Status

defect
RESOLVED DUPLICATE of bug 1045753
5 years ago
5 years ago

People

(Reporter: jliebson, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:30.0) Gecko/20100101 Firefox/30.0 ZemanaAID/FFFF009F (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

I have entered a number of recipients in the To: box, and every one of them is instantly removed, so that I cannot write email.

Windows 7 Home Premium 64-bit.

I fixed this on one computer by disabling two extensions, but on the other computer, even when running Tb in Safe Mode, the fatal error persists. This is not seen with Tb 24.x.


Actual results:

Again, recipients removed.


Expected results:

Recipients should remain in To: box.
John, which extentinos did you disable on computer A?

On computer B where it still fails, what do you see in tools | error console?
Flags: needinfo?(jliebson)
(Reporter)

Comment 2

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #1)
> John, which extentinos did you disable on computer A?
> 
> On computer B where it still fails, what do you see in tools | error console?

1. Signature Switch 1.6.12, and Stationery 0.8.4.

2. I can reinstall Tb 30.0 easily enough; I will do that tomorrow and check the error console, post any relevant information in this bug report.

3. Working backwards, my thanks for entering into the discussion, while numbered 3 is actually number 1.
Check if you have any contacts that do have empty e-mail or name parameters. 

I had similar issue in 31.0 due to LDAP filter set too wide and matching accounts with no mail and displayName attributes - such "contacts" were displayed as empty string at the top of autocomplete suggestion. It was LDAP, but some empty contact in local address book might produce same result. 

Please refero to bug 1042766 for details.
(Reporter)

Comment 4

5 years ago
Wayne: I removed Tb 24.x, reinstalled 30.0. When I opened the error console, I found a long list of items, which all seemed to be references to actions taken by Tb when it starts. I then went to Computer A, and checked the console there, which seemed to be the same as on Computer B.

On B, I cleared the error console, then tried writing a few emails. Curiously, the address for my wife, who has computer A, although in red (a problem being discussed on mozillZine) worked, and I did find one other at random, which, as I don't recall what it was, I could not repeat the trial.

I then looked at the error console, which was empty.
Flags: needinfo?(jliebson)
(Reporter)

Comment 5

5 years ago
MIchal: I do appreciate your assistance; unfortunately, most of what you provided, especially the link to bug 1042766, which has a link to another bug, is not in my language set, which tends to be in more "useful" languages such as Anglo-Norman.

Suffice it to say that I don't comprehend what is in those two bugs, so if you would be willing to provide instructions of what you think I should change in Tb, in a fashion that is aimed at non-programmers, that would certainly be gratefully accepted.

Perhaps the little clue in my response just about this one, about at least two addresses seeming to work in Tb 30.0 would lead you further in assisting me.

Comment 6

5 years ago
After upgrading to 31.0, I am experiencing an issue where I can only send one email before having to restart Thunderbird.

I open Thunderbird and click "Reply" or "Reply All".  A reply window appears, but the "TO:" field is blank.  I am able to manually type out the email address to which I wish to send the reply.  If I try to Compose or Reply or Forward any other message, the TO: field is blank but, this time, it's also grey'd out.  This forces me to close Thunderbird and re-open it to send my next email.

There are no errors generated when clicking "Reply", "Forward", or "Compose".  Errors/Warnings upon Thunderbird loading:

    Timestamp: 07/25/2014 09:43:31 AM
    Warning: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
    Source File: resource://gre/modules/Preferences.jsm
    Line: 378

    Timestamp: 07/25/2014 09:43:31 AM
    Warning: mutating the [[Prototype]] of an object will cause your code to run very slowly; instead create the object with the correct initial [[Prototype]] value using Object.create
    Source File: resource://gre/components/steelApplication.js
    Line: 783

    Timestamp: 07/25/2014 09:43:32 AM
    Warning: Use of getPreventDefault() is deprecated.  Use defaultPrevented instead.
    Source File: https://www.mozilla.org/thunderbird/js/jquery/jquery-1.5.1.min.js
    Line: 16




    Linux Loki 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
    Thunderbird 31.0

Comment 7

5 years ago
Is there any additional information that I can provide that would be usefull in replicating and fixing this issue?
Could you tell us more on how it happens?
Keywords: regression
Or bug 1050933.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1045753

Comment 10

5 years ago
This has been resolved in the latest build: 1:31.2.0+build2-0ubuntu0.14.04.1

Comment 11

5 years ago
I apologize for my previous comment, as it is *not accurate*.
You need to log in before you can comment on or make changes to this bug.