'Submit a New app' link is missing from the header

VERIFIED FIXED in 2014-08-19

Status

Marketplace
Developer Pages
P4
normal
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: krupa, Assigned: dethe)

Tracking

({regression})

2014-08-19
x86
All
regression
Points:
---

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8461107 [details]
submit an app.png

steps to reproduce:
1. Load https://marketplace-dev.allizom.org/developers/submissions
2. Notice the links in the header


expected behavior:
'Submit a new app' link is listed in the header

actual behavior:
'Submit a new app' link is missing in the header
Is this really a blocker? Based on the PR comments it seems the menu itself is a mess but there is a way to reach the "submit a new app" link. I'm all for a new bug to rethink the submission flow header otherwise.
(Assignee)

Updated

4 years ago
Assignee: nobody → delza
(Reporter)

Comment 3

4 years ago
The most important function in the Developer Hub is App Submission. Linking to it in multiple places shouldn't be a problem. 

Until we have a clear redesign available from UX, let us not change links.

Right now, the 'Submit an app' link seems hidden among 4 other links in the header. Took me a while to find it (It might be just me but I'm sure other people will run into the same issue)
Assignee: delza → nobody

Comment 4

4 years ago
I have no problem with it being in both, its messy but bleh. Without a full redesign or UX input, its not the worst. At least we aren't hiding it in a sub menu somewhere you have to have to hover to get to.
(In reply to krupa raj[:krupa] from comment #3)
> The most important function in the Developer Hub is App Submission. Linking
> to it in multiple places shouldn't be a problem. 
> 
> Until we have a clear redesign available from UX, let us not change links.
> 
> Right now, the 'Submit an app' link seems hidden among 4 other links in the
> header. Took me a while to find it (It might be just me but I'm sure other
> people will run into the same issue)

Agreed, let's just put it in both places for now. Especially with the contrast of the greenish/grayish header, it makes it really hard to see those navigational links. And, at least for me, my eyes are immediately drawn to the white nav.
Krupa, the "My Submissions" link (and its drop-down menu) is also missing from the white navigational bar:

    http://cl.ly/image/3v0T2C192b3C/Screen%20Shot%202014-07-29%20at%209.27.24%20AM.png

Do you reckon that should also be preserved? I think so.
(Reporter)

Comment 7

4 years ago
(In reply to Christopher Van Wiemeersch [:cvan] from comment #6)
> Krupa, the "My Submissions" link (and its drop-down menu) is also missing
> from the white navigational bar:
> 
>    
> http://cl.ly/image/3v0T2C192b3C/Screen%20Shot%202014-07-29%20at%209.27.
> 24%20AM.png
> 
> Do you reckon that should also be preserved? I think so.

Let us not change existing links unless UX recommends them.
(Assignee)

Comment 8

4 years ago
Is Tony Santos UX enough? Taking the "My Submissions" link out is exactly what this bug specified (once it was narrowed down to "do what it says in Comment 13"). https://bugzilla.mozilla.org/show_bug.cgi?id=860373#c13

Updated

4 years ago
Priority: -- → P4
(Assignee)

Updated

4 years ago
Assignee: nobody → delza
(Assignee)

Comment 9

4 years ago
Fixed in PR https://github.com/mozilla/zamboni/pull/2352

Happy to add back the drop-down list later if we have (some) consensus about it.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: 2014-07-29 → 2014-08-19

Comment 10

4 years ago
Verified in FF34(Win7) in marketplace-dev.allizom.org
Postfix screencast: http://screencast.com/t/OxQO1ADr
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.