Closed Bug 10430 Opened 21 years ago Closed 20 years ago

[DOGFOOD] Using the Tab key kills the caret and selection

Categories

(Core :: Editor, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED DUPLICATE of bug 10688

People

(Reporter: cmanske, Assigned: mozeditor)

Details

Start the editor. Click to place the caret. Type something -- characters are
inserted fine and caret moves.
Press the tab key:
Some space is inserted, and you can type more characters, but the caret has
disappeared and you can't click anywhere else to move the caret or make a
selection.
Not sure who to assign this to.
Assignee: buster → jfrancis
charlie, I assume this is in HTML editor only?  not plaintext?
I just looked at this. The problem is that tab key causes focus to move from
the editor document, which in turn turns off the selection.

There seem to be two problems; first, the editor should intercept the tab key,
if it's not an edit field. Second, the tab handling code should not move the
selection away from the editor, because there is no other widget in the window
that can have focus (as far as I can see).
Correct. I don't see the problem in plain text editor.
Summary: Using the Tab key kills the caret and selection → [DOGFOOD] Using the Tab key kills the caret and selection
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
*** This bug has been marked as a duplicate of 10688 ***
Status: RESOLVED → VERIFIED
verifed in 7/28 build.
You need to log in before you can comment on or make changes to this bug.