[B2G][Flame][Browser] Web page redirect does not function correctly

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Browser
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: rpribble, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-flame-test-run-3], URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8461196 [details]
Logcat.txt

Description:
Web pages are not redirecting correctly.  The page (people.mozilla.com/~nhirata/html_tp/redirect.html) appears to continuously reload but the page never appears.

Repro Steps:
1) Update a Flame to BuildID: 20140723000201
2) Connect to wifi or data
3) Launch browser and navigate to people.mozilla.com/~nhirata/html_tp/redirect.html

Actual:
The page appears to continuously redirect but never loads.

Expected:
Web page redirect functions as intended.

v2.0 Environmental Variables:
Device: Flame v2.0 MOZ ril
BuildID: 20140723000201
Gaia: bf3fb88039843359d0a5759b2c0fb787abae544f
Gecko: 57c44a3f83f6
Version: 32.0
Firmware Version: v122

Notes:

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/1625/
See attached: Video, logcat

---------------------------------------------

This issue occurs on the Flame v2.1, Buri v2.1, Flame v2.0, Buri v2.0, Flame v1.4, and Buri v1.4.

Environmental Variables:
Device: Flame Master (273MB)
Build ID: 20140723040201
Gaia: 01d86c8cc615658694b114ca5711763efc4ef205
Gecko: d0f6259e8446
Version: 34.0a1 (Master)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Buri Master
Build ID: 20140723073021
Gaia: 01d86c8cc615658694b114ca5711763efc4ef205
Gecko: 717cd9d89a80
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0

Environmental Variables:
Device: Flame 2.0 MOZ ril 
Build ID: 20140723000201
Gaia: bf3fb88039843359d0a5759b2c0fb787abae544f
Gecko: 57c44a3f83f6
Version: 32.0 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Buri 2.0 MOZ ril
Build ID: 20140723000201
Gaia: bf3fb88039843359d0a5759b2c0fb787abae544f
Gecko: 57c44a3f83f6
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Environmental Variables:
Device: Flame 1.4 MOZ ril (273MB)
Build ID: 20140723000202
Gaia: 5db3d93d68c30c1cf24499b3cda3fd881d207ea6
Gecko: 3dde355c32a1
Version: 30.0 (1.4)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Environmental Variables:
Device: Buri 1.4 MOZ ril
Build ID: 20140723000202
Gaia: 5db3d93d68c30c1cf24499b3cda3fd881d207ea6
Gecko: 3dde355c32a1
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

The page appears to continuously redirect but never loads.
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
(Reporter)

Comment 1

4 years ago
Note: 
The Flame 2.0 MOZ ril listed in the list of variables as reproducing the issue is set to 512MB memory.

User Agent of original Flame v2.0 (273MB) variables:
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Comment 2

4 years ago
Correction:
The variables for the Flame Master and the Flame v1.4 above should state that they are on the Firmware Version: v122.
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage? → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]

Comment 3

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.