[B2G][Window Mgmt][Downloads] Pressing on a Download Complete notification doesn't launch the file.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: dgomez, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.4 affected, b2g-v2.0 affected, b2g-v2.1 affected)

Details

(Whiteboard: [2.0-flame-test-run-3] [2.1-flame-test-run-1])

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8461217 [details]
Download_Complete.png

Description:
When a download completes and the Download Complete notification appears, pressing the notification does not open the downloaded file.

Note: This occurs with the following file types: .zip, .rar, .mp3, .jpg, .png, and .mp4

Repro Steps:
1) Update a Flame to 20140723000201
2) Download a file via the Browser app.
3) Wait for the file to finish downloading.
4) Once the Download Complete notification appears, press the notification.
5) Observe the screen.

Actual:
The downloaded file does not launch.
Expected:
The downloaded file launches.

2.0 Environmental Variables:
Device: Flame 2.0 (273MB)
Build ID: 20140723000201
Gaia: bf3fb88039843359d0a5759b2c0fb787abae544f
Gecko: 57c44a3f83f6
Version: 32.0 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Repro frequency: 6/6 - 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13565/
See attached: Logcat_Download_Complete.txt, Download_Complete.png
(Reporter)

Comment 1

4 years ago
Created attachment 8461220 [details]
Logcat_Download_Complete.txt

Attaching logcat.
(Reporter)

Comment 2

4 years ago
This issue DOES occur on Flame 2.1 (273MB), Flame 2.0 (512MB), Flame 1.4 (273MB), Buri 2.1, Buri 2.0, and Buri 1.4. 


Flame 2.1 (273MB)

Environmental Variables:
Device: Flame Master (273MB)
Build ID: 20140723040201
Gaia: 01d86c8cc615658694b114ca5711763efc4ef205
Gecko: d0f6259e8446
Version: 34.0a1 (Master)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Flame 2.0 (512MB)

Environmental Variables:
Device: Flame 2.0 (512MB)
Build ID: 20140723000201
Gaia: bf3fb88039843359d0a5759b2c0fb787abae544f
Gecko: 57c44a3f83f6
Version: 32.0 (2.0) 
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Flame 1.4 (273MB)

Environmental Variables:
Device: Flame 1.4 (273MB)
Build ID: 20140723000202
Gaia: 5db3d93d68c30c1cf24499b3cda3fd881d207ea6
Gecko: 3dde355c32a1
Version: 30.0 (1.4)
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Buri 2.1

Environmental Variables:
Device: Buri Master
Build ID: 20140723073021
Gaia: 01d86c8cc615658694b114ca5711763efc4ef205
Gecko: 717cd9d89a80
Version: 34.0a1 (Master)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0


Buri 2.0

Environmental Variables:
Device: Buri 2.0
Build ID: 20140723000201
Gaia: bf3fb88039843359d0a5759b2c0fb787abae544f
Gecko: 57c44a3f83f6
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 1.4

Environmental Variables:
Device: Buri 1.4
Build ID: 20140723000202
Gaia: 5db3d93d68c30c1cf24499b3cda3fd881d207ea6
Gecko: 3dde355c32a1
Version: 30.0 (1.4)
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0


Result: The user remains on the same screen and the downloaded file does not launch.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Does this occur on the Buri 1.3?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(dgomez)
(Reporter)

Comment 4

4 years ago
Could not check Buri 1.3 as Downloading via the Browser was not an available feature.
Flags: needinfo?(dgomez) → needinfo?(ktucker)
(Reporter)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage?]
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
QA Whiteboard: [QAnalyst-Triage+][lead-review+] → [QAnalyst-Triage?][lead-review+]
Flags: needinfo?(dharris)
Whiteboard: [2.0-flame-test-run-3] → [2.0-flame-test-run-3] [2.1-flame-test-run-1]
QA Whiteboard: [QAnalyst-Triage?][lead-review+] → [QAnalyst-Triage+][lead-review+]
Flags: needinfo?(dharris)
Can we try testing this on an older 1.4 build to see if this reproduces?
QA Whiteboard: [QAnalyst-Triage+][lead-review+]
Keywords: qawanted
I checked the build below with a .zip file and found that I get messages saying "Unable to open" "There isn't an app that can open [file.zip] Would you like to save the file or delete it?". So it looks like it's trying to open the .zip file but can't find a program to do so.

I tried to download a .mp3 file from mp3.com on the same build and it said "File not found" "The file wasn't found on the device."

I then went and checked the reporters build and definitely saw that on his build, nothing happens when tapping the banner.

Environmental Variables:
Device: Flame 1.4
BuildID: 20140507063006
Gaia: bac831d2ebc567f0939e41fbd8a4c15ef183b954
Gecko: 28299f693ddf
Version: 30.0 (1.4) 
Firmware Version: v122
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Contact: croesch
Duplicate of this bug: 1037334
It seems this bug is already fixed on latest Flame v2.0 and v1.4.  
- v1.4 build that reproduced this bug is 20140818000201.
- V2.0 build that reproduces this bug is 20140818000201

*********************************************************************************

V2.0 build which does NOT reproduce
-------------------------------------------------------------
Gaia      3df0c5f1ee3e208d1e8cbfe399baf1095e673c4f
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/ef6277f356d9
BuildID   20140818160200
Version   32.0
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

V1.4 build which does NOT reproduce
--------------------------------------------------------------------
Gaia      3e53eb07bf1c2cafeba53812ebe91835089723d3
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/c45814bfd93b
BuildID   20140818160201
Version   30.0
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014

*********************************************************************************

V2.0 build that reproduces this issue
-----------------------------------------------------------------------------
Gaia      fb2dd31abed2803eb7ad67eb4c52abb48de1e0f7
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/09f7a7184c71
BuildID   20140818000201
Version   32.0
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014

V1.4 build that reproduces this issue
-----------------------------------------------------------------------------
Gaia      21bec64497dc06a7f12071d573570ba8fea598ae
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/d4e14a98b165
BuildID   20140818000201
Version   30.0
ro.build.version.incremental=369
ro.build.date=Thu Aug 14 14:06:56 CST 2014
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → WORKSFORME
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
You need to log in before you can comment on or make changes to this bug.