In Message app, using a different keyboard layout type than English enables capslocks

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: delphine, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.4 unaffected, b2g-v2.0 unaffected, b2g-v2.1 unaffected)

Details

(I suspect it's the same issue as mentioned in Bug 1031505)
Noticed on latest master, on Flame device
Seems like this happens as long as you are using a different keyboard layout than the English one - whether switching from one keyboard layout to another, or using a different one than English from the start.

STRs:
* Have the device in French (because of different keyboard layout) OR choose French keyboard layout
* start writing a message (I tried both when the message was still contained in 1 total message space, and another time when it took up 2 message space)
* go in your message, and start adding words in it, taking some out, changing the spelling, until the cap lock issue I've already described happens (it shouldn't take too long before issue happens)

Result:
using a different keyboard layout type than English enables capslocks, forever onwards (impossible to deactivate it)
[Blocking Requested - why for this release]: regression
blocking-b2g: --- → 2.1?
status-b2g-v1.4: --- → unaffected
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
Keywords: regression
This might be a regression since bug 1036075.
Keywords: regressionwindow-wanted
I could not reproduce this issue with the fix in bug 1036075, following the steps in comment 0.

Delphine,

Could you please help verify this issue could be reproduced with bug 1036075 or not?
Or please help provide a specific step that could help to reproduce this issue.

Thanks.
Flags: needinfo?(lebedel.delphine)
removing regression-window wanted tag, as this issue seems to no longer occur for us either (waiting on Delphine for final confirmation)
Keywords: regressionwindow-wanted
Wasn't able to reproduce this on today's master, on Flame. Marking as resolved worksforme.
Seems like I have no chance with this bug, it just pops in and out of existence :)
Status: NEW → RESOLVED
blocking-b2g: 2.1? → ---
Last Resolved: 4 years ago
Flags: needinfo?(lebedel.delphine)
Resolution: --- → WORKSFORME
status-b2g-v2.1: affected → unaffected
You need to log in before you can comment on or make changes to this bug.