leaking nsIFolderListeners

RESOLVED DUPLICATE of bug 365723

Status

MailNews Core
Backend
RESOLVED DUPLICATE of bug 365723
17 years ago
9 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

({memory-leak})

Trunk
x86
Windows 2000
memory-leak

Firefox Tracking Flags

(Not tracked)

Details

(URL)

we are leaking nsIFolderListeners.

in addition to the leak, I'll see if we are creating more than we need, in the 
common case.
the initial 3 pane sets up 5 listeners, one is the status bar biff manager.

a second 3 pane sets up 4 listeners, close it we leak one.
a stand alone msg window sets up 3, close it, we leak one.

Status: NEW → ASSIGNED

Updated

17 years ago
Keywords: mlk, nsbeta1
QA Contact: esther → stephend

Comment 2

17 years ago
plussing for now but can minus when push comes to shove.
Keywords: nsbeta1 → nsbeta1+

Updated

17 years ago
Priority: -- → P3

Updated

16 years ago
Priority: P3 → P2
Target Milestone: --- → mozilla1.0

Updated

16 years ago
Keywords: nsbeta1+ → nsbeta1-
Target Milestone: mozilla1.0 → mozilla1.2
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW
Assignee: mail → nobody
Component: MailNews: Main Mail Window → MailNews: Backend
Priority: P2 → --
Product: Mozilla Application Suite → Core
QA Contact: stephend → backend
Target Milestone: mozilla1.2alpha → ---
(In reply to comment #1)

Is this leak(s) duplicate of bug 365723 ?

(I don't know if these numbers meant too much listeners or not...)
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
I think given that we fixed listeners in bug 365723 and there were no remaining leaks from it, I think this one is a dupe of that. If we find more later, we can always open another bug.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 365723
You need to log in before you can comment on or make changes to this bug.