Status

SeaMonkey
Startup & Profiles
--
major
VERIFIED FIXED
17 years ago
14 years ago

People

(Reporter: Robinson Franklin Bruginski, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
x86
Windows 95

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

In the picture in this new version.
I get about 3min to answer what profile i want to use.

for only do this I think that doesn't need all this time

i analize before.
the mozilla open and have disk acess.
disk stop seeking, and processor go to 100%
and continues for all time about 3-4minuts

I have a AMD 300MHZ 64MB RAM swap 128mb

and take another big time before i choose the profile

Reproducible: Always
Steps to Reproduce:
1.open mozilla
2.
3.

Expected Results:  in past version the profiles dont take all this time.
and the computer don't go only processing.


when mozilla is loading becase 100% of use of processor for big time.
the computers hang, looks like use a thread in higest priority

other problem, when i use mozilla for big times, opening all pages.
the computer is comming more and more slower, when i look, the swap space is
full, and system inform out of memory.
the mozilla only allocates memory? dont reliase??
thanks.
Suns


I know make programs in C/C++ in linux and windows, I interessed in help mozilla
community, but is hard for me help, becase I don't speak english in fisth
language... I speak portuguese.
sorry for my english
Reporter:
1. Your english isn't bad (my english sucks :-)
2. Have you installed mozilla in a fresh directory (not over an older build) ?
3. We know that mozilla use many memory and we are working on this problem
4. We know also that mozilla leaks memory (search bugzilla with the keyword 
   "mlk")
5. 64MB RAM is the minimum and maybe your system has problems with mozilla  
   because mozilla use too many RAM (swapping to disk is slow)
6. Mozilla 0.9.4 is faster than 0.9.3 on my system (ok my system is fast)
7. Mozilla 0.9.4 isn't new, it's old. Mozilla 0.9.5 will released in the next few 
    days
8. Can you try a nightly build ?
   (ftp://ftp.mozilla.org/pub/mozilla/nightly/latest-0.9.5/mozilla-win32.zip)
9. BTW: Please only one problem in a bug not two :-)
10.If you want to help us (we need help !): 
   http://www.mozilla.org/get-involved.html
   http://www.mozilla.org/hacking/
   http://www.mozilla.org/build/

Severity: critical → major
(Reporter)

Comment 2

17 years ago
yes fist i unistalled mozilla.
and when i install this version, i put in other dir.

to load the profiles, in other version i have.
loads fast than this.

I think in the load of profiles, mozilla loads the XUL's plataform
to buttons, etc.
but for profiles only dont need this. a simply window, to select the user is fine

no the mozilla when i open only it doesn't use swap file.
the strange here, is
I installed the 0.9.3 again in other dir, and it dont take all this time to
loads profiles, and the time to load mozilla is minor of now
Is it also slow if you try it with a new profile ?
(run "mozilla -profilemanager" and create a additional profile)

(Reporter)

Comment 4

17 years ago
The solution is in the version...

I got Build 2001101203
and all oks.

thanks to tell me to take the newest version..

but, all oks with no talkback build...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 5

17 years ago
Verified. Problem resolved with new build (2001101203) per reporter.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.