[Lockscreen] notifications are not stretching across the screen

RESOLVED FIXED

Status

Firefox OS
Gaia::System::Lockscreen
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8461240 [details]
screenshot

Minor bug.  the notifications on the lockscreen are not being stretched across the real estate of the screen.  The heading is stopping about 3/4 way. 

"Screenshot save... just now"   should extend as long as the description below it.

ni? ux team if this is by design or a bug.

repro:
1) install 2.0 build on flame

Gaia      bf3fb88039843359d0a5759b2c0fb787abae544f
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/57c44a3f83f6
BuildID   20140723000201
Version   32.0
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

2) have a few lockscreen notifications added.  Easiest way is just take some device screenshots

3) Verify the heading is ending early and not justified like the description is


Expected:
- the heading is as long as the description
Flags: needinfo?(firefoxos-ux-bugzilla)

Comment 1

3 years ago
Flagging Rob.
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
Flagging Amy in visual design. 

Amy, feel free to NI if you feel this goes beyond visual. Thanks!
Flags: needinfo?(rmacdonald) → needinfo?(amlee)

Comment 3

3 years ago
(In reply to Rob MacDonald [:robmac] from comment #2)
> Flagging Amy in visual design. 
> 
> Amy, feel free to NI if you feel this goes beyond visual. Thanks!

Hi Rob, 

I've been working with John on implementing the visuals for notifications. This is indeed a bug. Going to NI John to see if he knows why the text is appearing like that.
Flags: needinfo?(amlee) → needinfo?(jlu)
Hi Tony,

I'm sure bug 1041945 fixes it on master. Please try locally cherry-picking that patch on your 2.0 branch and see if the issue is resolved. If so, we can nominate blocking-2.0 on that bug. Thanks!
Flags: needinfo?(jlu)
(Reporter)

Comment 5

3 years ago
(In reply to John Lu [:mnjul] [MoCoTPE] from comment #4)
> Hi Tony,
> 
> I'm sure bug 1041945 fixes it on master. Please try locally cherry-picking
> that patch on your 2.0 branch and see if the issue is resolved. If so, we
> can nominate blocking-2.0 on that bug. Thanks!

Looks like it's fixed on master.   i dont think this bug is uplift worthy to 2.0, as its really polish work.  So this fix can ride the train.  Thanks!
(Reporter)

Comment 6

3 years ago
Fixed by bug 1041945
Blocks: 1041945
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.