Allow mState==DECODER_STATE_DORMANT in MediaDecoderStateMachine::ResetPlayback()

RESOLVED FIXED in mozilla34

Status

()

Core
Audio/Video
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: jwwang, Assigned: jwwang)

Tracking

Trunk
mozilla34
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
When FlushDecoding() [1] is called in dormant state, it will call ResetPlayback() and the assertion will fail at [2]. We should allow |mState==DECODER_STATE_DORMANT| in the assertion.


[1] http://hg.mozilla.org/mozilla-central/file/30907d52c4c2/content/media/MediaDecoderStateMachine.cpp#l2294

[2] http://hg.mozilla.org/mozilla-central/file/30907d52c4c2/content/media/MediaDecoderStateMachine.cpp#l1408
(Assignee)

Comment 1

4 years ago
Created attachment 8461280 [details] [diff] [review]
1043111_fix_ResetPlayback_in_dormant.patch

See comment 0 for the root cause.
Assignee: nobody → jwwang
Status: NEW → ASSIGNED
Attachment #8461280 - Flags: review?(kinetik)
Attachment #8461280 - Flags: review?(kinetik) → review+
(Assignee)

Updated

4 years ago
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/b97c05712090
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34
You need to log in before you can comment on or make changes to this bug.