Chrome shouldn't be affected by page's css

RESOLVED DUPLICATE of bug 1041530

Status

()

RESOLVED DUPLICATE of bug 1041530
4 years ago
4 years ago

People

(Reporter: hadakushal, Unassigned)

Tracking

Trunk
x86
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:34.0) Gecko/20100101 Firefox/34.0 (Beta/Release)
Build ID: 20140723030202

Steps to reproduce:

1. Create an html file as in https://gist.githubusercontent.com/9034725985/e594ea619199af1cdd01/raw/7f13f1fa8889df22c235127614c4bee5d07c12f4/youtube.html 

--
<!DOCTYPE html>
<html>
<head>
<style>
#masthead-positioner {
transform: translateZ(0);
}
#masthead-appbar {
background-color: #fff;
height: 40px;
}
</style>
</head>
<body>
<div id="masthead-positioner">
<div id="masthead-appbar">
</div>
</div>
</body>
</html>
-- 

2. Open Mozilla Firefox nightly in Microsoft Windows. 

3. In a maximized window of Mozilla Firefox, open our html file from above. 


Actual results:

Notice that there is a black bar above the awesome bar 


Expected results:

No black bar should be visible. More broadly, the css of a page should not affect window chrome.
(Reporter)

Comment 1

4 years ago
Created attachment 8461305 [details]
Initially discovered on YouTube website

This is what I see in the latest nightly when opening the said file above.

Comment 2

4 years ago
I can confirm this bug.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041530
You need to log in before you can comment on or make changes to this bug.