The download list does not show ongoing download progress if a download is in process

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
P2
normal
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: cynthiatang, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v1.4 affected, b2g-v2.0 affected)

Details

(Whiteboard: [1.4-dolphin-test-run-1][systemsfe])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8461318 [details]
screenshot.png

Device    Dolphin    
Gaia      6e4eaa5befce9c1812e07bcc78b2138645bdbe7a
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/2d16ba0b45bc
BuildID   20140723160201
Version   30.0
ro.build.version.incremental=272
ro.build.date=Mon Jul  7 14:44:46 CST 2014

STR:
Having a URL with several downloads to test download manager https://owd.tid.es/dm/

1. Open a web page in the browser which we can download files
2. Click on a file to download it
3. Opening Settings / Download list if a download is in process

Actual Result:
The download list does not show ongoing download progress, as shown in screenshot.png

Expected result:
The download list shows ongoing download progress


Note: 
It also happens in Flam.
Gaia      6e4eaa5befce9c1812e07bcc78b2138645bdbe7a
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/2d16ba0b45bc
BuildID   20140723160201
Version   30.0
ro.build.version.incremental=272
ro.build.date=Mon Jul  7 14:44:46 CST 2014
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
blocking-b2g: --- → 1.4?
status-b2g-v1.4: --- → affected
status-b2g-v2.0: --- → affected
Whiteboard: [1.4-dolphin-test-run-1]

Comment 2

4 years ago
Hi Arthur,

Could you take a look this one and provide your comments.
Flags: needinfo?(arthur.chen)
I'm not familiar with the code of download manager. Flagging ted instead.
Flags: needinfo?(arthur.chen) → needinfo?(tclancy)

Updated

4 years ago
Assignee: nobody → tclancy
Flags: needinfo?(tclancy)
I did an emulator build using the stated gecko and gaia versions. I can't reproduce this on the emulator. Should I try to reproduce it on a Dolphin?

Also, what's a Dolphin? I haven't seen this device. Where can I get one?
Whiteboard: [1.4-dolphin-test-run-1] → [1.4-dolphin-test-run-1][systemsfe]
(Reporter)

Comment 5

4 years ago
(In reply to Ted Clancy [:tedders1] from comment #4)
> I did an emulator build using the stated gecko and gaia versions. I can't
> reproduce this on the emulator. Should I try to reproduce it on a Dolphin?
> 
> Also, what's a Dolphin? I haven't seen this device. Where can I get one?

It also happens in Flame.
Gaia      6e4eaa5befce9c1812e07bcc78b2138645bdbe7a
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/2d16ba0b45bc
BuildID   20140723160201
Version   30.0
ro.build.version.incremental=272
ro.build.date=Mon Jul  7 14:44:46 CST 2014
move to backlog, as this is new feature
blocking-b2g: 1.4? → backlog
Priority: -- → P2

Updated

3 years ago
Assignee: tclancy → nobody
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog

Comment 7

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.