[OPENC_1.3]the video and the audio play simultaneously

RESOLVED WORKSFORME

Status

Firefox OS
AudioChannel
RESOLVED WORKSFORME
4 years ago
2 years ago

People

(Reporter: wangxiao, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:2.0.1) Gecko/20100101 Firefox/4.0.1 (Beta/Release)
Build ID: 20110413222027

Steps to reproduce:

1.Testing machine is playing a audio file
2.Testing machine received a video file sent from another phone(eg. bluetooth)
3.Find this received video file from status bar, and click it to play



Actual results:

The video and the audio play simultaneously


Expected results:

Music is automatically suspended, and the video is played.
when the video file plays completely,the audio file can be playback manually.
(Reporter)

Updated

4 years ago
OS: All → Gonk (Firefox OS)
Hardware: All → ARM

Comment 1

2 years ago
Moving to AudioChannel component so the right folks see this.
Component: Gaia::Music → AudioChannel
This issue was solved by new audio channel architecture.
I test this issue on following buildID - 20151026115812, and I can't reproduce it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.