javascript strict warnings in outliner.xml

RESOLVED FIXED in mozilla1.1alpha

Status

()

RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: simmo, Assigned: hyatt)

Tracking

Trunk
mozilla1.1alpha
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
js strict warnings in outliner.xml:

Warning: redeclaration of var sib
Source File:
chrome://global/content/bindings/outliner.xml#outlinercol-base.onDragMouseMove()
Line: 25, Column: 16
Source Code:
            var sib = col.mTargetCol._previousVisibleColumn;


Warning: redeclaration of var sib
Source File:
chrome://global/content/bindings/outliner.xml#outlinercol-base.onDragMouseMove()
Line: 38, Column: 18
Source Code:
              var sib = targetCol._previousVisibleColumn;


Warning: redeclaration of var sib
Source File:
chrome://global/content/bindings/outliner.xml#outlinercol-base.onDragMouseUp()
Line: 11, Column: 18
Source Code:
              var sib = col.mTargetCol._previousVisibleColumn;
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

17 years ago
Created attachment 53419 [details] [diff] [review]
patch; fixes js strict warnings (made using patch-maker v.0.4 on win2k)

Updated

17 years ago
Keywords: patch

Updated

17 years ago
Target Milestone: --- → mozilla1.0

Comment 2

17 years ago
*** Bug 106019 has been marked as a duplicate of this bug. ***

Comment 3

17 years ago
hyatt was begging to check this in.
Assignee: blakeross → hyatt
Target Milestone: mozilla1.0 → ---

Updated

17 years ago
Summary: js strict warnings in outliner.xml → javascript strict warnings in outliner.xml
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.1

Updated

17 years ago
Attachment #53419 - Flags: review+
This is fixed in tree.xml which is outliner's succesor.  Resolving.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.