Ok and Cancel buttons are hidden behind the soft home button on Nexus-4 in system dialogs.

RESOLVED WONTFIX

Status

Firefox OS
Gaia
--
critical
RESOLVED WONTFIX
4 years ago
4 months ago

People

(Reporter: Jukka Jylänki, Unassigned)

Tracking

({foxfood})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

4 years ago
Created attachment 8461530 [details]
IMG_20140724_163840.jpg

The system dialogs that pop up have their OK/Cancel buttons rendered underneath the home button. 

This was seen to occur at least in two different dialogs:
  - the incoming debug connection dialog. See the attached image of an example if this case.
  - the "packaged application hard-crashed the phone, do you want to report it?" dialog

Comment 1

4 years ago
Created attachment 8482552 [details]
Screen-dump showing the soft home button hiding the dialogue

Comment 2

4 years ago
Is this the same error as the one in the attachment I just added? Please advice if I shall file a separate bug.
This error was found on Boot2Gecko 2.1.0.0-prerelease Buildidentifier 20140831160203
(Reporter)

Comment 3

4 years ago
I think the underlying issue is the same, but since it occurs in a different menu and the steps to repro are different, I think it warrants opening a bug item of its own, to raise awareness that the issue is occurring in a different menu as well. Perhaps in the worst case the fixes will need to be separately done so having two separate issues will be helpful, but I'm not sure.

Comment 4

4 years ago
Bug 1061472 filed for the SW update confirmation issue
(Reporter)

Comment 5

3 years ago
Got the foxfooding Ignite phone this week, and this issue occurs on that as well.

A new way to reproduce, for example navigate the browser to https://www.khronos.org/registry/webgl/sdk/tests/webgl-conformance-tests.html and try to run the tests on the phone. There is another bug that the browser will crash when running the tests, and that will prompt up a crash report dialog, which will be hidden underneath the home button.
(Reporter)

Updated

3 years ago
Keywords: foxfood
(Reporter)

Comment 6

3 years ago
Created attachment 8627438 [details]
IMG_20150625_122752.jpg

Another screenshot showing the issue in the foxfooding phone.

Comment 7

4 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.