Problem with editing keywords, probably in globals.pl

RESOLVED DUPLICATE of bug 83474

Status

()

Bugzilla
Administration
--
minor
RESOLVED DUPLICATE of bug 83474
17 years ago
6 years ago

People

(Reporter: Andy C. Brandt, Assigned: justdave)

Tracking

Details

(Reporter)

Description

17 years ago
While trying to edit one of the previously entered keywords the user who is in 
charge of our bug reporting got this error:

Software error:
SELECT profiles.userid, profiles.groupset, profiles.login_name, 
profiles.login_name = 'danowski@swd.net.pl' AND profiles.cryptpassword = 
logincookies.cryptpassword AND logincookies.hostname = '192.39.188.218', 
profiles.disabledtext  FROM profiles, logincookies WHERE logincookies.cookie 
= '45' AND profiles.userid = logincookies.userid: Table 'profiles' was not 
locked with LOCK TABLES at globals.pl line 214.

For help, please send mail to the webmaster (andy@swd.net.pl), giving this 
error message and the time and date of the error. 

This error occurs when the description of a previously defined keyword is 
altered. Then Bugzilla suggests a cache rebuild and the sanity check is run. 
The error message pasted above is displayed at the end of the sanity check run. 
However, the description contents is being updated.
I'm not sure how this happens in practice.  Off hand, the following
possibilities come to mind:

- You did the rebuild twice.
- You hadn't used the keyword before.

*** This bug has been marked as a duplicate of 83474 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

17 years ago
No, we didn't do it twice. But indeed, the keyword is not yet used in any bug.
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.