An image with max-height as 100% inside a parent with a fixed max-height overflows beyond it's parents bounds

RESOLVED DUPLICATE of bug 816679

Status

()

Core
General
RESOLVED DUPLICATE of bug 816679
4 years ago
4 years ago

People

(Reporter: Amsul, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/35.0.1916.153 Safari/537.36

Steps to reproduce:

Added CSS to make an element with a fixed max-height.
Then inserted an image within that element with a max-height of 100%.


Actual results:

The image overflows beyond the bounds of the parent element.


Expected results:

The image should be resized down to the parent's max-height.

Here's the test case: http://jsfiddle.net/wfGwm/
Works fine in Webkit. IE has the same bug.

Comment 1

4 years ago
Thanks for the report. This works as designed, see the explanation in bug 930749.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Component: Untriaged → General
Product: Firefox → Core
Resolution: --- → DUPLICATE
Duplicate of bug: 816679
You need to log in before you can comment on or make changes to this bug.