error: 'mutationCount' was not declared in this scope

RESOLVED FIXED

Status

Firefox OS
GonkIntegration
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: m4, Assigned: njn)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
From change https://bugzilla.mozilla.org/show_bug.cgi?id=1038601, HashTable::mutationCount is declared conditionally based on the JS_DEBUG pound define [1] but used conditionally by DEBUG pound define [2].  In some builds, DEBUG is defined but JS_DEBUG is not.

Perhaps mutationCount should be pulled out and wrapped by DEBUG instead.

[1] https://github.com/mozilla/gecko-dev/blob/256a1f168b345758d1ce83f6575d6543f8bec738/js/public/HashTable.h#L1005
[2] https://github.com/mozilla/gecko-dev/blob/256a1f168b345758d1ce83f6575d6543f8bec738/js/public/HashTable.h#L1089
Oh, since I've posted a fix patch as a follow-up in bug 1038601, how about we just continue things there?
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1038601
I'm reopening this bug because a patch has already landed in bug 1038601.  It's confusing to post follow-up patches to bugs that are already RESOLVED.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Created attachment 8470641 [details] [diff] [review]
Fix up DEBUG/JS_DEBUG confusion in HashTable.h

Moving the patch from bug 1038601 to here.
Assignee: nobody → n.nethercote
Status: REOPENED → ASSIGNED
Comment on attachment 8470641 [details] [diff] [review]
Fix up DEBUG/JS_DEBUG confusion in HashTable.h

Review of attachment 8470641 [details] [diff] [review]:
-----------------------------------------------------------------

Carrying over r+ from bug bug 1038601.
Attachment #8470641 - Flags: review+
https://hg.mozilla.org/mozilla-central/rev/e4f87d728f9d
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.