date/time custom fields storage problem in different timezones

RESOLVED DUPLICATE of bug 946090

Status

()

Bugzilla
Bugzilla-General
RESOLVED DUPLICATE of bug 946090
4 years ago
4 years ago

People

(Reporter: Fedor Ezeev, Unassigned)

Tracking

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140605174243

Steps to reproduce:

1. Have two users of one bugzilla installation in different timezones (MSK and UTC, for example). Local time on server is MSK.
2. Have vanilla bugzilla installation with MySQL server, with one custom field, named StartsOn, with date/time type.
3. User at MSK timezone (manager) add a bug with StartsOn value '25.07.2014 12:00', and this means, that this task should be started to work on it at '25.07.2014 12:00 MSK' or '25.07.2014 08:00 UTC' respectively.


Actual results:

User at UTC timezone (prog) views, that StartsOn value of new bug is '25.07.2014 12:00', and he starts to work on it at '25.07.2014 12:00 UTC', or 4 hours later, than he should to.


Expected results:

User at UTC timezone should see '25.07.2014 08:00' value at StartsOn custom field.

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 946090
You need to log in before you can comment on or make changes to this bug.