Closed Bug 1043684 Opened 6 years ago Closed 6 years ago

call log entry hijacked by contact with alphabetically prior first letter

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1044028

People

(Reporter: dietrich, Unassigned)

References

Details

As detailed in bug 1029581, a contact with same number but alphabetically lower character steals the log entry.

STR:

1. create contact B with a phone number.
2. call B, confirm B is the call log entry.
3. create contact A with same phone number as B.
4. open call log.

Expected: Call log entry is contact B.

Actual: Call log entry is contact A.
I don't think this is a "bug". If you have two contacts with the same phone number, the call log information is correct whether we display A or B. Also, that would make our code base more complex for no user value so I'll close this as WONTFIX.
Mentor: anthony
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Mentor: anthony
See Also: → 1044028
Bugs like this remove the point of supporting multiple contacts per number in the first place*. If we're going to support multiple contacts per number, it should be done in a way that makes sense to the user and how they use the device.

And for that feature, a call log entry should always keep the contact id that was selected by the user to be called.

Requesting UX input to help design the proper behaviour.

Is it quite complex to keep a contact id with a call log record? It seems quite simpler that the complicated associate-a-contact-at-runtime stuff going on now, but maybe I don't understand the code. The fix for bug 1029581 seemed to be going in that direction anyway - and that direction made sense looking at that patch.

* I don't think having multiple contacts is necessary, but it for certification it is, so here we are :)
Status: RESOLVED → REOPENED
Flags: needinfo?(firefoxos-ux-bugzilla)
Resolution: WONTFIX → ---
This is for Carrie and Wilfred to think on. :)
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(firefoxos-ux-bugzilla)
Flags: needinfo?(cawang)
I agree that keeping the contact id makes sense and that's what we'll do in bug 1044028.
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(cawang)
Resolution: --- → WONTFIX
Ok, thanks rik, marking duplicate then!
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1044028
You need to log in before you can comment on or make changes to this bug.