Setting wallpaper from camera doesn't work

RESOLVED DUPLICATE of bug 1041811

Status

RESOLVED DUPLICATE of bug 1041811
5 years ago
5 years ago

People

(Reporter: kairo, Assigned: mancas)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2.0-319MB-bug-bash])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Build Information
Device: Flame
Gaia      29266e18c35f4e72e35f1bba0e34f2fb6b995cc3
Gecko     https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/178fe2efc41d
BuildID   20140724000201
Version   32.0
ro.build.version.incremental=109
ro.build.date=Mon Jun 16 16:51:29 CST 2014
B1TC00011220

Description
When trying to set a wallpaper from the camera, you never can select it.

Steps to Reproduce
1) Go into Settings > Display
2) Tap the edit icon to set a new wallpaper
3) Select "Camera" from applications
4) Take a photo
5) Tap "Select"

Expected Results
Picture is being set as wallpaper.

Actual Results
"Select" button never triggers.

Other Notes
I can reproduce this both on 319MB Flame with 2.0 and on 1GB Flame with 2.1

Reproduction Frequency: 
Tried twice on 319MB 2.0, once on 1GB 2.1, reproduces always.
(Reporter)

Comment 1

5 years ago
Using front or back camera also doesn't make any difference, even trying "Retake" multiple times.
(Reporter)

Comment 2

5 years ago
FWIW, the pictures I tried to select end up in the Gallery and are selectable as wallpapers from there though.
QA Wanted - can someone else reproduce this?
Keywords: qawanted
(Assignee)

Updated

5 years ago
Assignee: nobody → b.mcb
(Assignee)

Comment 4

5 years ago
Created attachment 8462478 [details] [review]
Configure the Device Storage

The problem was that the device storage was trying to delete the original image taken by the camera, and after that, save the new image resized. However, the device storage was not configured
Attachment #8462478 - Flags: review?(dmarcos)
Dup. Patch waiting for review in 1041811
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1041811
Attachment #8462478 - Flags: review?(dmarcos)
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.