Occasional text/font corruption on web pages

RESOLVED DUPLICATE of bug 83289

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 83289
17 years ago
16 years ago

People

(Reporter: Jeremy Sanders, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bae:20011211], URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.5+) Gecko/20011010
BuildID:    2001101008

When scrolling quickly, Mozilla sometimes stretches text that was half-covered
by the top of the page before scrolling. It's very difficult to reproduce, but I
see it typically a few times a day when using Mozilla. I can reproduce it on the
current state of http://bugzilla.mozilla.org/show_bug.cgi?id=104362 (see
screenshot). It seems to vary on the size of the window, the type of font used
(sans-serif is easiest to corrupt), and its size.



Reproducible: Sometimes
Steps to Reproduce:
1. Scroll page so a line (in large font) in half-covered.
2. Scroll page with scroll-bar quickly upwards.
3. Repeat until some text looks corrupted

Actual Results:  A line of text gets corrupted.



Expected Results:  The font should look the same, no matter how quickly you scroll.

Using XFree86 4.0.3 on 24 bit display on Matrox G400 AGP on Linux.
(Reporter)

Comment 1

17 years ago
Created attachment 53255 [details]
example of font corruption

Comment 2

16 years ago
This sounds like some of the other DPI issues we have been seeing.

Comment 3

16 years ago
Jeremy, are you using the default settings under Preferences|Appearance|Font? 
What do you have them set to? Are you using text zoom? I can't reproduce the 
problem you described using the build from 20011211 on win98. Of course, this 
could be a linux only issue.
Whiteboard: [bae:20011211]

Comment 4

16 years ago
Based on the steps provided, I can't seem to reproduce the problem shown.
Reporter, can you please provide additional information ? Tested under Linux build 
(2001-12-05-06)
(Reporter)

Comment 5

16 years ago
I think this is a dup of bug 83289, where if the DPI setting is not one of the
standard ones you get pixel rendering bugs. I am using non-standard fonts (Arial
16 pixels in the X Windows Truetype renderer), but it happens with the standard
X windows fonts too.

Comment 6

16 years ago
Marking as a dup of 83289, if it ends up not being a dup, please reopen

*** This bug has been marked as a duplicate of 83289 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.