hover location bar history forces going to hovered address even if canceled

RESOLVED DUPLICATE of bug 1043584

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 1043584
3 years ago
3 years ago

People

(Reporter: Bjorn, Unassigned)

Tracking

31 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

Click on location bar and start typing a web address. Firefox will auto-fill the most likely website you're trying to visit and pops down a history of previously visited websites. Hover over any website in the history but don't click it! Now move the mouse back the location bar. Click it and press enter to browse towards the website that was auto-filled. It will browse to the website that was hovered instead.


Actual results:

Firefox browses to the hovered website instead of the one auto-filled. For example: I type in "G" firefox auto-filles it to "google.com". In history I hover "https://www.mozilla.org/en-US/about/". Now I click on the location bar again (still "google.com" inside). Press enter and it browses to the about page instead of Google.com


Expected results:

Firefox should've browsed to the web address that was auto-filled.
(Reporter)

Updated

3 years ago
Component: Untriaged → Location Bar

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043584
You need to log in before you can comment on or make changes to this bug.