Mozilla will never exit if you quit it by closing Mailnews

VERIFIED WORKSFORME

Status

--
critical
VERIFIED WORKSFORME
17 years ago
10 years ago

People

(Reporter: hwaara, Assigned: mscott)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
This is very bad. With this testcase, Mozilla will never terminate, and I'll 
have to do Ctrl-Alt-Delete to quit it!

1. Open a few browser windows, and a Mailnews window
2. Browse around some using the windows (that's what I usually do :)
3. Click the "X" in all browser windows, keeping only mailnews left open
4. Close mailnews by clicking the "X".

I am filing this in XPCOM, if this is wrong, feel free to move it around. CCing 
some mailnews folks too.
(Reporter)

Comment 1

17 years ago
To rephrase: visually, it looks like Mozilla has quit, but it is still in 
memory -- and I need to ctrl-alt-delete to free it from memory. Thus, this 
should impact the OS' footprint.

Comment 2

17 years ago
please tell me you haven't (accidentally) turned on quick launch. Edit |
Preferences | Advanced "Enable Quick Launch"
(Reporter)

Comment 3

17 years ago
I haven't (enabled Quick Launch).

Comment 4

17 years ago
over to mailnews for investigation.
Assignee: dougt → mscott
Component: XPCOM → Mail Back End
Product: Browser → MailNews
QA Contact: scc → esther

Comment 5

17 years ago
hwaara, are you still seeing this?  I haven't had any luck reproducing this.
(Reporter)

Comment 6

17 years ago
Yes, still seeing it in my 2001-10-16 build if I close the mailnews window as
the last window.  I'll try to reproduce in a later build ...

Comment 7

17 years ago
20020116
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
I can't reproduce this with build 2002-01-29-03, therefore Verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.