compile tier rebuilds everything that depend on libxul on windows when libxul is changed

RESOLVED FIXED in mozilla34

Status

()

Core
Build Config
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: glandium, Assigned: glandium)

Tracking

unspecified
mozilla34
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

4 years ago
This is actually related to the binaries target support. It's only a problem on windows because on other platforms, there's no ambiguity between import libraries and static libraries, and the build system makes the difference.

Note that before bug 1043344, the same was true for the libs tier, it just moved to the compile tier. Which bug 1043862 will make apparent in mach build binaries, which doesn't have this behavior on windows at the moment.
(Assignee)

Comment 1

4 years ago
Created attachment 8462547 [details] [diff] [review]
Derive build dependencies for programs and libraries from make backend data instead of getting them from expandlibs
Attachment #8462547 - Flags: review?(gps)

Comment 2

4 years ago
Comment on attachment 8462547 [details] [diff] [review]
Derive build dependencies for programs and libraries from make backend data instead of getting them from expandlibs

I'm going to deflect this one to mshal. Been doing too many build reviews this week.
Attachment #8462547 - Flags: review?(gps) → review?(mshal)
Comment on attachment 8462547 [details] [diff] [review]
Derive build dependencies for programs and libraries from make backend data instead of getting them from expandlibs

I think it looks fine. I haven't fully verified all of the dependency changes in the rules, though.
Attachment #8462547 - Flags: review?(mshal) → review+
https://hg.mozilla.org/mozilla-central/rev/b9051530561e
https://hg.mozilla.org/mozilla-central/rev/65520f089f40
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla34

Comment 7

4 years ago
(From Bug 1045329 comment #13)

>> expandlibs_gen.py: error: no such option: --depend
>> c:/t1/hg/comm-central/config/rules.mk:766: recipe for target
>> 'db_mork_src.lib.desc' failed
>> mozmake[2]: *** [db_mork_src.lib.desc] Error 2
>>  mozmake[2]: Leaving directory 'c:/t1/hg/objdir-sm/db/mork/src'
> 
> This looks like a different issue, likely caused by bug 1043869.

Is there a bug filed for this regression?
(Assignee)

Comment 8

4 years ago
(In reply to Philip Chee from comment #7)
> > This looks like a different issue, likely caused by bug 1043869.
> 
> Is there a bug filed for this regression?

bug 1044460
QA Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.