Index letter is missing when Tapping a letter on the index of a contacts list

RESOLVED FIXED in Firefox OS v2.0

Status

P1
normal
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: mchang, Assigned: chens)

Tracking

({perf})

unspecified
2.1 S7 (24Oct)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.0M verified, b2g-v2.1 unaffected, b2g-v2.2 verified)

Details

(Whiteboard: [c=effect p= s= u=])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
If we have a list of contacts and try to quickly go to a letter, for example going from 'A' to 'Z' while scrolling the index list, or quickly tapping a single letter, we see some low resolution tiling. We also have some amount of latency between tapping an index and the contacts showing up. The first priority should be trying to improve the low resolution tiling when we scroll / tap the index list.
(Reporter)

Updated

4 years ago
Whiteboard: [systemsfe][c=effect p= s= u=] → [c=effect p= s= u=]
(Reporter)

Comment 1

4 years ago
Created attachment 8462476 [details]
Video of bug

We see that we sometimes blank white, have low res tiling, and there is some latency between when we touch a letter and when we show the information. This is an issue the partner has brought up.
(Reporter)

Comment 2

4 years ago
Any thoughts on what we could do about this issue? Thanks!
Flags: needinfo?(milan)
Flags: needinfo?(francisco)
Seems to be two issues you're mentioning in this bug - chance of checkerboarding that low res tiling avoids and the latency on touching the letter, which sounds a lot like bug 1028834.

For the first issue, if it looks like we may checkerboard, because a lot of things changed and we can't reuse previous tiles, we will do the low res draw.  Otherwise, we'd probably checkerboard.  So, it's pretty much by design that this happens.
Flags: needinfo?(milan)
(Reporter)

Updated

4 years ago
Depends on: 1028834
I agree with milan here, when changing a group we checkerboard cause we cannot reuse any tile since everything changes.
Flags: needinfo?(francisco)
(Reporter)

Comment 5

4 years ago
Hi Jeff, will you be able to use a high speed camera and measure the time it takes between when a user lifts their finger and when the screen shows checkerboarding / low res tiling? By design, since those contact lists are not in the displayport we have to paint the new tiles. If the time between when the user lifts their finger and when the checkerboarding occurs is somewhat low, that would help UX and the graphics team determine what steps to do next. Thanks!
Flags: needinfo?(faraojh)
Mason,

Are you going to be tracking this bug still?
Flags: needinfo?(mchang)
(Reporter)

Comment 7

4 years ago
Hi Wayne,

Sorry, but I don't think I will have any time to track or fix this issue in any reasonable timeframe.
Flags: needinfo?(mchang)
Hi Evelyn, Luke,

As you can see from the video, sometime when you tap the contact index on the right side of the screen, it will only show a green circle without a character inside. Could you help to check this one? I can show you how to reproduce it

Thanks

Vance
Flags: needinfo?(lchang)
Flags: needinfo?(faraojh)
Flags: needinfo?(ehung)

Comment 9

4 years ago
Vance, may I know which build/device we are aiming for?
Flags: needinfo?(vchen)
Flags: needinfo?(lchang)
Flags: needinfo?(ehung)
It is on Madai 2.0, and I think Flame 2.0 has this issue as well

Thanks

Vance
Flags: needinfo?(vchen)

Comment 11

4 years ago
@Chens, could you help here? Thanks!
Flags: needinfo?(shchen)
(Assignee)

Comment 12

4 years ago
Confirm this issue also repro on flame master. 
I will look into how we show a green circle on right side.
Flags: needinfo?(shchen)
(Assignee)

Comment 13

4 years ago
Created attachment 8492831 [details]
Contacts-EmptyCircle.png
(Assignee)

Comment 14

4 years ago
Created attachment 8492832 [details]
Contacts-LowReso.png
(Assignee)

Comment 15

4 years ago
Vance, is attachment 8492831 [details] the same situation as you described in comment 8?

I found this could happen if you scroll to favorite or search on the top of scrollbar.
(Assignee)

Updated

4 years ago
Flags: needinfo?(vchen)
(In reply to Sherman Chen [:chens] from comment #15)
> Vance, is attachment 8492831 [details] the same situation as you described
> in comment 8?
> 
> I found this could happen if you scroll to favorite or search on the top of
> scrollbar.

Ya something like that, just a green circle without character inside it, but not sure if it must be search to favorite or search of the top of scrollbar. 

The way I test is to populate 200 contact data into phone via |make reference-workload-light|, then start to test by randomly tapping the index on the right, as i remember, can also reproduce in both middle or bottom part of the scrollbar

Thanks!
Flags: needinfo?(vchen)
(Assignee)

Comment 17

4 years ago
Created attachment 8492975 [details] [review]
Pull request to 2.0
(Assignee)

Comment 18

4 years ago
attachment 8492975 [details] [review] could possibly solve issue mentioned in comment 8.
Note this is only wip patch and did not solve the low reso problem.
(Assignee)

Comment 19

4 years ago
Vance, do we need this on 2.0?
Flags: needinfo?(vchen)
Yes this one is needed for 2.0

Thanks
Flags: needinfo?(vchen)
(Assignee)

Updated

4 years ago
Attachment #8492975 - Flags: review?(etienne)
(Assignee)

Comment 21

4 years ago
[Blocking Requested - why for this release]: As comment 20, we need this for 2.0
blocking-b2g: --- → 2.0?
Comment on attachment 8492975 [details] [review]
Pull request to 2.0

redirecting to a contact peer
Attachment #8492975 - Flags: review?(etienne) → review?(sergi.mansilla)
Performance improvements usually do not block the release. See the blocking criteria here: https://wiki.mozilla.org/B2G/Triage#Blocker_Triage_Guidelines

Mason, do you know if this is a regression? We auto-block on regressions.

If this is not a regression or broken new feature, we shouldn't block, and let this ride the trainz.
Flags: needinfo?(mchang)
Hi Dietrich -

The reason to nominate this one as a blocker is because partner strongly ask for it to be fixed in order to bring better user experience to end users.
(Reporter)

Comment 25

4 years ago
To my knowledge this is not a regression. I filed this bug because the partner is interested in having this solved, but essentially it's a case where we can't paint fast enough.
Flags: needinfo?(mchang)
Triage:2.0+, since this is strongly requested by Partner.

Hi Sherman, thanks for your efforts.
May I know if the WIP patch could resolve issues of low precision tiling and long latency, and also the index letter inside circle is missing ?   

Thank you very much.
Flags: needinfo?(shchen)
(Assignee)

Comment 27

4 years ago
(In reply to Rachelle Yang [:ryang][ryang@mozilla.com] from comment #26)
> Hi Sherman, thanks for your efforts.
> May I know if the WIP patch could resolve issues of low precision tiling and
> long latency, and also the index letter inside circle is missing ?   

No, as per comment 18, this patch only solve index letter missing and it's still pending review.
Flags: needinfo?(shchen)
(Assignee)

Comment 28

4 years ago
Hi Rachelle, 

Based on comment 26, I think we should update blocking-b2g flag to 2.0+ right?
Flags: needinfo?(ryang)
Hi Sherman, thanks for your remind. set it to 2.0+.

BTW, do you mind sparing some time on the issues of low precision tiling and long latency of contacts?
Or do you prefer I create another bug for the issue ?
Thank you very much!
blocking-b2g: 2.0? → 2.0+
Flags: needinfo?(ryang) → needinfo?(shchen)
(Assignee)

Comment 30

4 years ago
Yes, I think we should separate these two. Create another bug for either low precision tiling or index letter missing is fine. I can move attachment 8492975 [details] [review] to corresponding bug if necessary.
Flags: needinfo?(shchen)
This is listed as depending on bug 1028834 - is it a blocking dependency?  In which case bug 1028834 would need to be a 2.0+ as well.
Hi Sherman, thanks for our suggestion.
I will keep Bug1043884 as issue of index letter missing, so you could keep your  attachment 8492975 [details] [review] here. Thanks!

BTW,Could you please kindly spare some time on bug 1028834 as well? 

Thank you very much !
Summary: Tapping a letter on the index of a contacts list shows low precision tiling and has long latency → Index letter is missing when Tapping a letter on the index of a contacts list
(Assignee)

Comment 33

4 years ago
Comment on attachment 8492975 [details] [review]
Pull request to 2.0

Hi Sergi, I'm not sure this is right way to go, would you review this patch and give some feedback?
Flags: needinfo?(sergi.mansilla)
Hi Sherman,

Can you tag me as reviewer instead of needinfo in this case? 

Thanks!
Flags: needinfo?(sergi.mansilla)
Oh, I see I am the reviewer, nevermind then :) I'll review it today.
Hi Sherman,

Could you please rebase your branch against current master?

Thanks!
Flags: needinfo?(shchen)
(Assignee)

Comment 37

4 years ago
Sure, and sorry I have to create another branch since I can't reopen the pull request, will provide new pull request later.
Flags: needinfo?(shchen)
I've gone ahead and re-opened the PR if it helps.
(Assignee)

Comment 39

4 years ago
Thanks Kevin, that really helps :)
(Assignee)

Comment 40

4 years ago
Hi Sergi,

I've rebase the branch to latest 2.0, would you take a look? thanks!
(Assignee)

Comment 41

4 years ago
ni Sergi for comment 40.
Flags: needinfo?(sergi.mansilla)
Thanks Sherman! I'll take a look.
Flags: needinfo?(sergi.mansilla)
Hi Sherman,

I flashed your patch in a peak device, and a normal 2.0 in another one. I am testing and trying to reproduce the issue but I can't see any difference. Could you let me know how to reproduce the exact issue your patch solves?

Thanks!
Flags: needinfo?(shchen)
(Assignee)

Comment 44

4 years ago
This is how I reproduce this issue: 

1. Open contacts app
2. Click on the index letter shortcut on the right side
3. Green overlay shows up with no index letter in it

I also upload a video: http://youtu.be/6THABNmyo7c
Flags: needinfo?(shchen)
Thanks Sherman, I was able to reproduce it. Your patch seems to fix it, but there is still a small issue: after touch up, the letter disappears before the circle fades out. Could we have the letter and the circle disappear at the same time?

Thanks!
Flags: needinfo?(shchen)
(Assignee)

Comment 46

4 years ago
It was intended to imitate the behavior when you scroll along the index letter shortcut. When scroll ends, the index letter in circle will disappear first, and the circle will disappear later. I can also make them disappear at the same time, so I would like to confirm which way should go for?
Flags: needinfo?(shchen) → needinfo?(sergi.mansilla)
Hi Sherman,

I added a couple of comments to the PR; after those are fixed I think it is ready to be merged. As for the letter/circle timing, we should create another issue to address that and CC somebody from UX like Fang.
Flags: needinfo?(sergi.mansilla) → needinfo?(shchen)
(Assignee)

Comment 48

4 years ago
Hi Sergi, 

I've updated the PR and addressed those comments, could you review it again? 
And I agree we should create another bug and get UX involved to discuss the behavior.

Thanks :)
Flags: needinfo?(shchen)
Comment on attachment 8492975 [details] [review]
Pull request to 2.0

Looks good, r=me
Attachment #8492975 - Flags: review?(sergi.mansilla) → review+
(Assignee)

Comment 50

4 years ago
Comment on attachment 8492975 [details] [review]
Pull request to 2.0

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): 
[User impact] if declined: Bad user experience, index letter not showing when tapping index shortcut.
[Testing completed]: Manual test + unit test
[Risk to taking this patch] (and alternatives if risky): Low risk and no alternatives.
[String changes made]: None
Attachment #8492975 - Attachment description: wip → Pull request to 2.0
Attachment #8492975 - Flags: approval-gaia-v2.0?

Comment 51

4 years ago
Hi! Chens,

Since you are working on this case. Assign this to you.
Thanks

--
Keven
Assignee: nobody → shchen
(In reply to Sherman Chen [:chens] from comment #50)
> Comment on attachment 8492975 [details] [review]
> Pull request to 2.0
> 
> NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to
> better understand the B2G approval process and landings.
> 
> [Approval Request Comment]
> [Bug caused by] (feature/regressing bug #): 
> [User impact] if declined: Bad user experience, index letter not showing
> when tapping index shortcut.
> [Testing completed]: Manual test + unit test
> [Risk to taking this patch] (and alternatives if risky): Low risk and no
> alternatives.
> [String changes made]: None

why is not landed on master/2.1 yet ?

Updated

4 years ago
Flags: needinfo?(shchen)
(Assignee)

Comment 53

4 years ago
This issue doesn't reproduce on master/2.1
Flags: needinfo?(shchen)
Merged at 280f8e33e6810e6cf43ffbae4b4b530fdbd54cd0.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Attachment #8492975 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
v2.0: https://github.com/mozilla-b2g/gaia/commit/a2719af81cfdb330eecf37cd6f4725ec75123aed
status-b2g-v2.0: --- → fixed
status-b2g-v2.1: --- → unaffected
status-b2g-v2.2: --- → fixed
Target Milestone: --- → 2.1 S7 (24Oct)

Comment 57

4 years ago
This issue has been verified successfully on Woodduck 2.0;Flame2.0&2.2.
Reproducing rate: 0/5
See attachment: Verify_Woodduck_Cantactletter.mp4

Woodduck build version:
Gaia-Rev        d742e375aca6dc1bf3a36638000ad7f5338ef457
Gecko-Rev       d049d4ef127844121c9cf14d2e8ca91fd9045fcb
Build-ID        20141126050313
Version         32.0

Flame2.0 build version:
Gaia-Rev        99e4594c66aa3738d58b0cb44bd885a87a063b6e
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g32_v2_0/rev/f91abc6127d9
Build-ID        20141125000201
Version         32.0

Flame2.2 build version:
Gaia-Rev        824a61cccec4c69be9a86ad5cb629a1f61fa142f
Gecko-Rev       https://hg.mozilla.org/mozilla-central/rev/acde07cb4e4d
Build-ID        20141125040209
Version         36.0a1
status-b2g-v2.0: fixed → verified
status-b2g-v2.0M: fixed → verified
status-b2g-v2.2: fixed → verified

Comment 58

4 years ago
Created attachment 8528849 [details]
Verify_Woodduck_Cantactletter.MP4
You need to log in before you can comment on or make changes to this bug.