Closed Bug 1043935 Opened 6 years ago Closed 6 years ago

toolbarbutton of type="menu-button" image and text alignment issue

Categories

(Firefox :: Theme, defect, P5)

30 Branch
x86_64
Linux
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: saroyanm, Unassigned)

References

()

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/36.0.1985.125 Safari/537.36

Steps to reproduce:

1. Add toolbarbutton type="menu-button" into nav-bar, example:
<toolbarbutton id="tbt-toolbarButton" class="toolbarbutton-1" type="menu-button" label="my label" />
2. Use list-style-image property to add image
3. Change display property of toolbarbutton-text:
display: -moz-box !important;

Or simply install provided add-on.


Actual results:

The image and text positioned vertically (see: attached screenshot). 
Seams to be caused by current style:
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/toolbarbutton.css#102



Expected results:

Expected result is that the image and label are positioned horizontally.
Component: Untriaged → Theme
Priority: -- → P5
Attached image Screenshot of the issue
This is the default on Windows as well, and was before Australis. You can style the button with -moz-box-orient: horizontal to change it.

I'm not really sure why you filed this, considering that Wladimir already said on the ABP issue that the default theme doesn't let you change the button display mode on Firefox anymore, and from a toolkit perspective, displaying the text below the icon is perfectly valid and not actually a bug.

We could change the default everywhere by changing toolkit, but that would probably break other toolkit apps like SeaMonkey and Thunderbird which rely on these styles...
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → INVALID
Summary: toolbarbutton of type="menu-button" image and text alignment issue in Australis → toolbarbutton of type="menu-button" image and text alignment issue
(In reply to :Gijs Kruitbosch (Gone July 26 - August 3) from comment #2)

> I'm not really sure why you filed this, considering that Wladimir already
> said on the ABP issue that the default theme doesn't let you change the
> button display mode on Firefox anymore.

Yes you right. My bad.
Agree with closing the bug.
You need to log in before you can comment on or make changes to this bug.