Closed Bug 1044099 Opened 6 years ago Closed 6 years ago

Firefox 31 build error when system freetype is compiled with harfbuzz support

Categories

(Core :: Graphics: Text, defect)

31 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 847568

People

(Reporter: felix-mozilla, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Firefox/31.0 (Beta/Release)
Build ID: 20140716183446

Steps to reproduce:

My system freetype 2.5.3 is compiled with harfbuzz support, because that's the cool thing to do.

Firefox comes with its own freetype and harfbuzz, for some reason.  Firefox detects my freetype but not my harfbuzz, and attempts to build its own harfbuzz.

Firefox also attempts to compile harfbuzz with all hidden symbols, which leads to the build breaking with error messages like this:


Actual results:

../../../build/unix/gold/ld: warning: hidden symbol 'hb_shape' in /tmp/mozbuild/toolkit/library/build/../../../gfx/harfbuzz/src/hb-shape.o is referenced by DSO /usr/lib64/gcc/x86_64-unknown-linux-gnu/4.9.1/../../../../lib64/libfreetype.so
../../../build/unix/gold/ld: warning: hidden symbol 'hb_buffer_set_direction' in /tmp/mozbuild/toolkit/library/build/../../../gfx/harfbuzz/src/hb-buffer.o is referenced by DSO /usr/lib64/gcc/x86_64-unknown-linux-gnu/4.9.1/../../../../lib64/libfreetype.so
../../../build/unix/gold/ld: warning: hidden symbol 'hb_buffer_create' in /tmp/mozbuild/toolkit/library/build/../../../gfx/harfbuzz/src/hb-buffer.o is referenced by DSO /usr/lib64/gcc/x86_64-unknown-linux-gnu/4.9.1/../../../../lib64/libfreetype.so



Expected results:

Firefox should not have built its own harfbuzz but used the system one.
Or at least offer a configure option to tell it to do that.

BTW: I tried telling configure to use the in-tree freetype (which is clearly inferior to the system one because it explicitly compiles without harfbuzz support, which is puzzling to me), but configure then fails.

Here is the error message:

configuring in modules/freetype2
running /bin/sh /tmp/mozilla-release/modules/freetype2/configure  --x-includes=/usr/X11R7/include --x-libraries=/usr/X11R7/lib64 --prefix=/opt/firefox64 --with-system-zlib --enable-application=browser --enable-pango --enable-svg --enable-svg-renderer=cairo --enable-system-cairo --enable-strip --disable-debug '--enable-optimize=-O2\ -fPIC\ -pipe' --enable-official-branding --enable-default-toolkit=cairo-gtk2 --disable-necko-wifi --disable-gnomevfs --disable-gnomeui --disable-crashreporter --disable-pulseaudio --disable-dbus --with-system-libevent --with-system-libvpx --with-system-icu --disable-updater --disable-tests --enable-install-strip --enable-gio --enable-system-ffi --enable-system-pixman --with-system-jpeg --disable-gstreamer --enable-tree-freetype --host=x86_64-unknown-linux-gnu --disable-shared --with-pic=yes --with-zlib=yes --without-bzip2 --with-png=yes --without-harfbuzz --cache-file=../.././config.cache --srcdir=/tmp/mozilla-release/modules/freetype2
/tmp/mozilla-release/modules/freetype2/configure: line 96: test: /tmp/mozilla-release/modules/freetype2: integer expression expected
Never mind about the configure failure, that appears to be my fault.
Component: Untriaged → Graphics: Text
Product: Firefox → Core
I expect this is a dupe of one or more of bug 847568 and bug 986580

I'm picking the former because it seems like the most plausible.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 847568
You need to log in before you can comment on or make changes to this bug.