bluetooth file transfer shows black screen from the Gallery app, until reboot

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Gallery
RESOLVED WONTFIX
4 years ago
3 months ago

People

(Reporter: dietrich, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Flame, nightly, July 25

STR:

1. Send a file from Gallery over Bluetooth to Mac
2. Weren't paired, so pair
3. File is sent, worked fine
4. Tried another file, Gallery app turns into black screen
5. Kill Gallery from Task Manager, try again, same thing
6. Reboot
7. Try again - not paired! But they pair (again) fine and file is sent.

I couldn't reproduce, so don't have logcat :(
(Reporter)

Updated

4 years ago
Keywords: regression
QA Wanted to see if someone else can reproduce.
Keywords: qawanted

Updated

4 years ago
QA Contact: ddixon
Hi Dietrich - we are attempting to reproduce your bug and needed some clarification. In your repro steps:

4. Tried another file, Gallery app turns into black screen 


When you "tried another file" did the file successfully send and THEN turn the screen black - or did just selecting the file to transfer turn the screen black? 

We are currently getting frequent error messages "file could not be sent" and are trying to figure out if perhaps the black screen might be a bad call to that error message. (unless you are getting a 'success' message and then get the black screen).
Flags: needinfo?(dietrich)
We do not have a Mac device available to test our devices for this issue.  

I tested this issue using Ubuntu.  

Actual Results: 
Files from Gallery app do not send via bluetooth to a computer running the Ubuntu operating system. User receives "File could not be sent" notification.  

Note: I did not see the "black screen" or freezing behaviour from the Gallery app. 

Repro Rate: 2/10 

Device: Flame Master
Build ID: 20140725160205
Gaia: dd42afb7d6d66a6c2bd999692fec6b6d553d23de
Gecko: e07264876182
Version: 34.0a1 (Master)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:34.0) Gecko/34.0 Firefox/34.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmitchell)
Keywords: qawanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmitchell)
(Reporter)

Comment 4

4 years ago
Second send was not successful. The screen of Gallery app went solid black upon attempting to send. IIRC it was when selecting Bluetooth from the share menu.
Flags: needinfo?(dietrich)
No-Jun - Do you have a Mac by chance? If so, can you try to reproduce this?
Flags: needinfo?(npark)

Updated

4 years ago
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
I tested transferring 3 image files in a row from the gallery app, but could not reproduce the issue.
(Using Flame device)

Gaia      df39c463259d348396ef7f143c2c780eeb8f02d8
Gecko     https://hg.mozilla.org/mozilla-central/rev/ffdd1a398105
BuildID   20140820040203
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
Flags: needinfo?(npark)
(Reporter)

Comment 7

4 years ago
Just saw this again. Flame, master, Sept 2 pull.

If I force quite the Gallery app and try again, I actually see a "no memory card" message! Crazy. Rebooting fixes.

Comment 8

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.