Closed Bug 1044191 Opened 6 years ago Closed 6 years ago

Compound clipPath not displaying in FF31.0 (Windows), with hardware acceleration (which is default-enabled)

Categories

(Core :: SVG, defect)

x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 915072

People

(Reporter: david.dailey, Unassigned)

References

()

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; HPDTDF; BRI/1; InfoPath.2; .NET4.0C; BRI/2; .NET4.0E; BOIE9;ENUSMSNIP; rv:11.0) like Gecko

Steps to reproduce:

http://cs.sru.edu/~ddailey/svgtests/clipPath4aCompound.svg


Actual results:

The clipped region applied as a clipPath doesn't display.
Robert Longson suggested in bug (https://bugzilla.mozilla.org/show_bug.cgi?id=1042865) that this was a separate issue from the animation issue in that bug.


Expected results:

I believe it did work in a prior version of FF, though I recall that it didn't for a time before that. On that bug see, Comment #5 from Daniel Holbert [:dholbert] <dholbert@mozilla.com> 2014-07-25 09:58:48 PDT ---
(I see all three stars in Firefox 31 on Ubuntu Linux, FWIW. That issue must be
platform and/or hardware-dependent.)
So it may just be FF31/Windows.
I forgot to mention, here, that the test in question does work as expected in Chrome, old and new Opera, Safari (Win), ASV, and IE11 (without the animation, of course).
I can confirm this bug locally on my laptop, with latest Firefox Nightly on Windows 8.1.  The clipPath4aCompound.svg renders with just a purple bar -- no star.

The bug goes away if I uncheck "use hardware acceleration" in Preferences | Advanced and restart Firefox.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Compound clipPath not displaying in FF31.0 (Windows) → Compound clipPath not displaying in FF31.0 (Windows), with hardware acceleration (which is default-enabled)
Version: 31 Branch → Trunk
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 915072
You need to log in before you can comment on or make changes to this bug.