Upcoming Events fails to load after viewing my events page

RESOLVED FIXED

Status

Webmaker
Events
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: cade, Assigned: cade)

Tracking

Details

(Whiteboard: [aug8])

Attachments

(1 attachment)

(Assignee)

Updated

4 years ago
Keywords: ateam-automation-task
(Assignee)

Updated

4 years ago
Whiteboard: [aug8]
He who spots problems fixes?
Assignee: nobody → cade
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
I've narrowed this down to line 113 of paginate-anything.js, which hadles the events pagination. when we hit the request function for events, $scope.url is undefined for some reason.
(Assignee)

Comment 3

4 years ago
Created attachment 8464078 [details] [review]
https://github.com/mozilla/webmaker-events-2/pull/167

There seems to be a race condition (albeit, a very easy to hit race condition) where the pagination directive can attempt to fetch events before the we-listing directive can set the serviceURL, so if we default the value, the problem is negated.
Attachment #8464078 - Flags: review?(gavin)

Updated

4 years ago
Attachment #8464078 - Flags: review?(gavin) → review+

Comment 4

4 years ago
Commit pushed to master at https://github.com/mozilla/webmaker-events-2

https://github.com/mozilla/webmaker-events-2/commit/80b88e9104de86ff130b25755948744d233d093e
Bug 1044204 - Default the serviceURL value so that pagination doesn't lose it's mind
(Assignee)

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.