[B2G][Card View]'No Recent Apps' not displayed after user closes all apps and long presses home

RESOLVED DUPLICATE of bug 1036718

Status

RESOLVED DUPLICATE of bug 1036718
4 years ago
4 years ago

People

(Reporter: rkuhlman, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.0 unaffected, b2g-v2.1 affected)

Details

(Whiteboard: [273MB-Flame-Support])

Attachments

(1 attachment)

Created attachment 8462839 [details]
HomeButtonLog.txt

If no apps are open, then the 'No Recent Apps' page should be displayed when the user long presses home to summon card view. This screen is not displayed if the user is in an app, brings up card view and closes all apps, then long presses the home button again from homescreen.

The 'No Recent Apps' page is properly displayed if the user returns to homescreen before summoning card view.

Repro Steps:
1) Update a Flame to BuildID: 20140725040205
2) Launch any app
3) Long press home button to access card view
4) Close all apps in card view. Device should return to homescreen at this point
5) Long press home button again

Actual:
Phone vibrates, otherwise nothing happens

Expected:
Card view should launch, and display the text: 'No Recent Apps'

Note: If the user taps home button to returns to homescreen between steps 2 and 3, then the expected result will occur

Master M/C Environmental Variables:
Device: Flame Master M/C
BuildID: 20140725040205
Gaia: 3a06aa58245eaf848242d6d1497c1af536fffabd
Gecko: 6c0971104909
Version: 34.0a1
Firmware Version: v122


Repro frequency: 100%
See attached: logcat
Issue does NOT occur in v2.0.The 'No Recent Apps' screen is properly displayed.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140725000201
Gaia: 9b6d7357031f2412b18a2fb140d5c974842d4393
Gecko: fbb3b8be8f6c
Version: 32.0 (2.0)
Firmware Version: v122
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

adding regression-window-wanted tag
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.0: --- → unaffected
status-b2g-v2.1: --- → affected
Flags: needinfo?(pbylenga)
Keywords: regression, regressionwindow-wanted, smoketest
Whiteboard: [273MB-Flame-Support]

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Keywords: regressionwindow-wanted, smoketest
Resolution: --- → DUPLICATE
Duplicate of bug: 1036718
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(pbylenga)
You need to log in before you can comment on or make changes to this bug.