Closed Bug 1044274 Opened 5 years ago Closed 5 years ago

[Gallery][RTL] gallery image view back button is not RTL

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(ux-b2g:2.1, b2g-v2.0 affected, b2g-v2.1 affected, b2g-v2.2 affected)

RESOLVED INVALID
ux-b2g 2.1
Tracking Status
b2g-v2.0 --- affected
b2g-v2.1 --- affected
b2g-v2.2 --- affected

People

(Reporter: nhirata, Assigned: pivanov)

References

Details

(Whiteboard: [2.0-319MB-bug-bash])

Attachments

(4 files)

Attached image 2014-07-25-15-15-27.png
1. set the device language to arabic
2. reboot the device
3. launch gallery
4. select an image

Expected: back arrow is RTL
Actual: back arrow is still LTR

Gaia      3a06aa58245eaf848242d6d1497c1af536fffabd
Gecko     https://hg.mozilla.org/mozilla-central/rev/6c0971104909
BuildID   20140725040205
Version   34.0a1
ro.build.version.incremental=110
ro.build.date=Fri Jun 27 15:57:58 CST 2014
B1TC00011230
flame
Whiteboard: [2.0-319MB-bug-bash]
Assigning to Pavel. Pavel, let me know if you need any UX guidance here. You should be able to view the correct/expected user experience elsewhere in the OS, but if not just ni? me. Thank you!
Assignee: nobody → pivanov
ux-b2g: --- → 2.1
I will take this :)
Attached file patch for Gaia/master
Attachment #8470682 - Flags: feedback?(nefzaoui.ahmed)
Comment on attachment 8470682 [details] [review]
patch for Gaia/master

I left some comments, one of them is critical for performance AFAIK, which is using PNG files instead of hacking on CSS :)
Let's get that changed first :)
Thanks!
Attachment #8470682 - Flags: feedback?(nefzaoui.ahmed) → feedback-
Thanks :)
Done :)
Flags: needinfo?(nefzaoui.ahmed)
Good to go.
TBH I like to have everything-RTL at the end of the file just like everywhere else.
But that's up to you, in any case it seems fine. :)
Flags: needinfo?(nefzaoui.ahmed)
Attachment #8470682 - Flags: review?(pdahiya)
Attachment #8470682 - Flags: feedback?(nefzaoui.ahmed)
Attachment #8470682 - Flags: feedback-
Attachment #8470682 - Flags: feedback?(nefzaoui.ahmed) → feedback+
Comment on attachment 8470682 [details] [review]
patch for Gaia/master

Thanks for the patch, it looks good and has my r+.
Attachment #8470682 - Flags: review?(pdahiya) → review+
Thanks :)

Landed to master:
https://github.com/mozilla-b2g/gaia/commit/bf52411cfa23a052df8b7b4845432282ae390eda
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Depends on: 1106814
Mass Edit: adding the [rtl-meta]
Whiteboard: [2.0-319MB-bug-bash] → [rtl-meta]
Whiteboard: [rtl-meta] → [rtl-meta][2.0-319MB-bug-bash]
QA Whiteboard: [rtl-impact]
Whiteboard: [rtl-meta][2.0-319MB-bug-bash] → [2.0-319MB-bug-bash]
Keywords: verifyme
This issue exist on Flame 2.2:
Gaia-Rev        7c5b27cad370db377b18a742d3f3fdb0070e899f
Gecko-Rev       https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/748b20315f75
Build-ID        20150114002502
Version         37.0a2
Reproduce rate  5/5
Flags: needinfo?(jocheng)
Attached image 2015-01-15-16-29-41.png
This issue exists on Flame2.2,refer to picture:2015-01-15-16-29-41.png
Hi Pavel, 
It seems the problem still exist at latest 2.2 build per comment 11. Could you please check again?
Thanks!
Flags: needinfo?(jocheng) → needinfo?(pivanov)
Sure,

I will take a look tomorrow. But I think that the screenshot from Comment 11 is not in RTL mode (see the toolbar at the bottom)
Flags: needinfo?(pivanov)
Ok so just talked offline with Ahmed. He confirms that according to UX specs, back button should not be mirrored here. Also, the toolbar at the bottom shouldn't be mirrored either. I'm going to attach a screenshot, but according to what I see on latest 2.2, there is therefore no RTL issue.
What confuses me is that this bug was not closed as Resolved-Invalid when it was opened, if this is in fact the correct RTL behavior. 
Needinfo on UX so they can confirm from my screenshot that everything is in fact RTL-compliant, before I close this bug as Resolved Invalid. Thanks!
Flags: needinfo?(firefoxos-ux-bugzilla)
Delphine, you are correct in comment #14: this should have been resolved invalid because the correct RTL behavior was already present. I'll do that now.
Flags: needinfo?(firefoxos-ux-bugzilla)
Resolution: FIXED → INVALID
According to Comment 14 and Comment 16, clear "verifyme" in keywords.
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.