bugzilla.mozilla.org will be intermittently unavailable on Saturday, March 24th, from 16:00 until 20:00 UTC.

Send Later using POP loses email, does not populate "Unsent Msgs"



MailNews Core
17 years ago
10 years ago


(Reporter: johng, Assigned: Jean-Francois Ducarroz)



Windows 98

Firefox Tracking Flags

(Not tracked)


(Whiteboard: [PDT-])



17 years ago
Netscape branch eMojo build from Thursday, 10/11:  20011011

- Online through remote dial-up connection
- Launched Netscape mail, successfully read and sent a few emails
- clicked offline
- disconnected my dial-up connection
- composed a few email messages, clicked "Send Later" to send them
- later reconnected my dial-up connection, then clicked online
- opened my Unsent messages folder, but it was empty (should have had 3 or 4
- Clicked "Send Unsent Messages". 
- Looked at Sent folder.  I think it added one msg to the Sent folder, but not
the others that I said "Send Later"

Comment 1

17 years ago
adding keywords and cc
Keywords: dataloss, nsbranch


17 years ago
Assignee: bienvenu → ducarroz
Component: Offline → Composition

Comment 2

17 years ago
-> JF. This is part of message sending, not offline per se. See bug 101828

Comment 3

17 years ago
According to the comments in bug 101828 the patch was in trunk and also was
checked into branch.  Before the fix went in for 101828 I was able to reproduce.  
I am using today's branch build and not able to reproduce this. But I am not on
a dial up machine. 

Comment 4

17 years ago
Only copy of the message to imap sent folder failed right? But did the actual
sending of messages work?

Comment 5

17 years ago
I also tried this on the dial-up machine in the lab. I used the branch build
from 2001-10-11 on win98 machine. I was not able to reproduce.  I followed the
steps below as mentioned. 
I went offline from the file menu item
I composed 4 messages while offline 
click on send later button
Messages were in the unsent message folder
I went back online.
I clicked on send button in the dlg which comes up when you go back online
Result: Messages were received in the account
Messages also were copied to the pop sent folder(not local sent folder)

Is there any specific steps that I need to be doing to see the bug. Are you able
to reproduce this again?

Comment 6

17 years ago
The PDT thinks John is high and should take a shower before filing bugs. ;-)

Comment 7

17 years ago
Tried the 10-11 branch build on NT 4.0. I wasn't using a
dial up connection but I could not replicate the problem
either using the steps to reproduce. Unsent folders
had my unsent mesgs and when I sent them, they were copied
to sent folder.

assigning qa to sheela.
QA Contact: gchan → sheelar

Comment 8

17 years ago
John, do you have more than one account set up?

Comment 9

17 years ago
Reproducable here.
10/11 build  WIN98  Cable modem
2 accounts set up.
Message: Unable to save your message in order to send it later.
         Please verify your Mail and Newsgroups account settings

Message: Copy failed

Comment 10

17 years ago
Tried 2 diff mail accounts on 10/11 branch build on nt 4.0

Tried 1 imap and 1 pop mail account and it worked.
Tried 2 pop accounts and it worked also.

Comment 11

17 years ago
Removed IMAP account leaving one POP account. No improvement.
Created new profile. Works as intended.
Old profile was created with version 0.93. Imap account never worked, was attemp
to use netscape web mail in 6.1.

Comment 12

17 years ago
Found prefs.js line shown below directing unsent to deleted server (closed
account). After deleting line unsent folder was created in local folders and am
unable to re-create a similar pref line.


Comment 13

17 years ago
is this an nsbranch- candidate, or is this something we need to fix on the branch?

Comment 14

17 years ago
sheela - can you actually go and take a look at john's system to troubleshoot

Comment 15

17 years ago
PDT-, but we should look at john's machine, and see if this is reproducible on 6.1
Whiteboard: [PDT-]

Comment 16

17 years ago
Esther said she called John and left a message that she wanted to see his
machine.  Still waiting for his reply.  

Comment 17

17 years ago
reproducing with Esther, here is the deal.

+ Send Later *does* populate the "Unsent Messages" folder, but the one in the
Local  Folder section.  The "Unsent Messages" folder that exists in my primary
POP account is never populated.

+ When you click "Send Unsent Messages", it does *not* send the messages that
have been stored in Local/Unsent Messages.

So "Send Later" saves to one folder, but "Send Unsent Messages" does not send
from that folder (perhaps it tries to send from a different place, but who
knows).  So "Send Unsent Messages" does not work, so using POP offline to send
messages does not work.

Additional data:

+ I got into this state using 6.1.  Migrated into 6.0 originally from 4.x, then
migrated to 6.01, then to 6.1 (with some daily builds along the way).

+ Migrating straight from 4.x appears to work.  Separate testing by Sheela shows
that if you migrate straight from 4.x, the Unsent Message folder is migrated
into the email account and works correctly (Send Later messages are stored
there, and "Send Unsent Messages" sends those correct messages).

Finally, other bugs that appear to deal with this issue:
bug 100857 investigating Send Unsent Messages
bug 88931 Unsent messages problems
bug 40692 multiple unsent messages folders

Comment 18

17 years ago
Branch build:  094-2001-10-22-18 win98

I migrated a 4.x profile with messages in unsent message folder to 6.0, 6.01,
6.1, and 6.2.  This profile has a pop account and the behavior after migrating
with messages in unsent message folder are as follows:
1. After migrating a pop account, we have 2 unsent message folder(known bug)
2. Messages in the unsent message folder from 4.x goes to pop unsent message
folder and not local folder unsent message folder
3. At this point local unsent message folder is not at all recognized
4. Create a new message and click on send later. The message goes to pop unsent
message folder. Whether you are online or offline does not matter the behavior
is the same.
5. Tried deleting the unsent message folder in pop and there is no way to get
rid  of this folder. It builds a new unsent message folder every time you
restart the application.

The above 1-5 was observed in 6.0, 6.01, 6.1, and 6.2.  I was not able to
reproduce the problem that John is seeing.  I could not get the messages to go
to local unsent message folder.  It always was going to pop unsent message
folder and sending unsent messages from that folder worked fine.

However, I remember using trunk builds, I was able to get rid off the unsent
message folder in pop after deleting it from the explorer.  After I restarted
the application my local unsent message folder was recognized and the messages
did go to this folder when sent later.  I have also successfully sent these
I see that in John's comments he did use the daily builds with this profile at
some point. So using one of the trunk builds made so that the local unsent
message folder was reset to save messages but still has problem sending from them.  
This is mostly likely related to one of the bugs listed here.  Because in one of
the bugs below seth mentioned that if the pop account gets deleted sending
unsent messages would fail.  There could be a combination of using daily trunk
builds that I have seen behave differently than the branch builds and also
deleting and creating the account might have caused this problem.  
But I was not able to reproduce it:(

Comment 19

17 years ago
I also tried another scenario. I migrated a pop profile with messages in unsent 
message folder from 4.x to 6.0. I tried to open the same profile using 6.01, 6.1 
and 6.2 builds to see if I could see the problem. I did not have problem sending 
message from the pop unsent message folder. As I said in my earlier in my 
comments that the local unsent message folder is not recognized.  

This is a dup of bug 100857. If bug 100857 gets resolved where we don't have 2 
unsent message folder is most unlikely that users will get into this problem.
I am marking is as a dup but if anyone here disagrees please reopen.  

*** This bug has been marked as a duplicate of 100857 ***
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 20

17 years ago
verified as dup 
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.