Vertical bars after spaces in mime encoded header with mixed characters

VERIFIED FIXED in mozilla0.9.9

Status

MailNews Core
Internationalization
P2
normal
VERIFIED FIXED
17 years ago
10 years ago

People

(Reporter: Dimitrios, Assigned: Takayuki Tei)

Tracking

({intl})

Trunk
mozilla0.9.9
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
As you can see on the attached screenshot, bold vertical bars are inserted when
there are spaces between latin and non latin characters. In the highlighted
message, subject contains some combinations of the "a" and "b" characters with
various ones from the greek alphabet. It is obvious that not all combinations
result in vertical bars. And there's no problem in message pane.

Build 2001101203 (note that I see it for months).
(Reporter)

Comment 1

17 years ago
Created attachment 53307 [details]
screenshot
(Reporter)

Comment 2

17 years ago
This is the message source for the highlighted header in the previous screenshot:

X-Accept-Language: el, en
MIME-Version: 1.0
To: dipa@ath.forthnet.gr
Subject: a =?ISO-8859-7?Q?=E1?= a =?ISO-8859-7?Q?=E2?= a 
	=?ISO-8859-7?Q?=E3?= a =?ISO-8859-7?Q?=E4?= a 
	=?ISO-8859-7?Q?=E5?= a =?ISO-8859-7?Q?=E6?= a 
	=?ISO-8859-7?Q?=E7?= a =?ISO-8859-7?Q?=E8?=     b 
	=?ISO-8859-7?Q?=E1?= b =?ISO-8859-7?Q?=E2?= b 
	=?ISO-8859-7?Q?=E3?= b =?ISO-8859-7?Q?=E4?= b 
	=?ISO-8859-7?Q?=E5?= b =?ISO-8859-7?Q?=E6?= b 
	=?ISO-8859-7?Q?=E7?= b =?ISO-8859-7?Q?=E8?= 
Content-Type: text/plain; charset=ISO-8859-7; format=flowed
Content-Transfer-Encoding: 7bit
Status:   

Comment 3

17 years ago
Confirm based on the screen shot?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

17 years ago
Status: NEW → ASSIGNED
Keywords: intl
(Reporter)

Comment 4

17 years ago
Created attachment 53324 [details]
Messages of the screenshot., Unzip this into Local Folders (but contains non latin characters)
(Reporter)

Comment 5

17 years ago
Created attachment 53325 [details]
Messages of the screenshot (better attempt)

Comment 6

17 years ago
On my Japanese XP with 10/12 0.9.4 build, Japanese period is displayed instead.

Comment 7

17 years ago
Tabs used for line folding are not removed and shown in thread pane. I think
jgmyers fixed this before, cc to him.

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 64948 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 9

17 years ago
Although this is also causing bug 64948, the root cause of this symptom
is different from bug 64948.  Folding long header is broken, thus
should be tracked as a different bug.  Re-opening.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 10

17 years ago
Reassign to myself.  Change TM to 0.9.6.
Assignee: nhotta → taka
Status: REOPENED → NEW
Target Milestone: --- → mozilla0.9.6
(Assignee)

Comment 11

17 years ago
Created attachment 56515 [details] [diff] [review]
proposed fix

Comment 12

17 years ago
Taka, could you put a decsription about your change?
Cc to ducarroz.

Comment 13

17 years ago
Bug 73403 tracks the error in the header encoder/folder.

(Assignee)

Comment 14

17 years ago
The new code checks if there is a LWSP character already at where we are
about to fold.  If there is, inserts CR/LF before this LWSP instead of
inserting extra TAB regardless which causes this symptom.  This way,
new code becomes RFC-822 compliant as opposed to the previous code.

As for MIME encoded word, it always uses SPACE as LWSP.

Status: NEW → ASSIGNED
(Assignee)

Comment 15

17 years ago
Shall we close this bug as dup of bug 73403 ?
(Assignee)

Comment 16

17 years ago
My conclusion is to deal with bug 73403 as a different problem from this bug.
Keep this bug opened.

Naoki,
Who can be s/sr for this propsed fix?

Comment 17

17 years ago
Added nsbeta1 keyword.
Keywords: nsbeta1
0.9.6 is out the door.

(Assignee)

Comment 19

17 years ago
change TM to 0.9.7.
Target Milestone: mozilla0.9.6 → mozilla0.9.7
(Assignee)

Comment 20

17 years ago
change TM to 0.9.8.

Priority: -- → P2
Target Milestone: mozilla0.9.7 → mozilla0.9.8
(Assignee)

Comment 21

17 years ago
Set TM to 0.9.9.
Target Milestone: mozilla0.9.8 → mozilla0.9.9
(Assignee)

Comment 22

17 years ago
As a result of new MIME encoder, which is originally written to fix #73403,
this bug should be also fixed by applying the proposed patch (id=67007) 
submitted on 1/29/2002.  Please down load and apply the patch and see how
it fixes this problem as well.
(Reporter)

Comment 23

17 years ago
I understand that, due to the "international" nature of this bug, I am pretty
responsible for testing the proposed fix. Alas, I don't have a building
environment available. Is it possible for someone else to make a build with this
pach? Thanks in advance. 

Comment 24

17 years ago
Just close it as dup of bug 73403 :-))
(Reporter)

Comment 25

16 years ago
Patch still makes Mail client unusable (build 2002020103) or even crashing
(build 2002013103). Tested on Win98 and Win2K.
(Assignee)

Comment 26

16 years ago
Don't think the files I gave you as patch.  It's crashing due to unresolved
symbols at runtime, not any other reason which might be introduced by the patch.

You have to download the patch for bug 73403, apply to your source tree,
and build by yourself.  Or, wait until the patch gets checked into CVS.
(Assignee)

Comment 27

16 years ago
add dependency
Depends on: 73403
(Assignee)

Comment 28

16 years ago
Mark as fixed.  See bug 73403 for detail.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → FIXED
(Reporter)

Comment 29

16 years ago
Yes!! All those ugly characters that were making my Mozilla Mail looking like a
home-made application have been vanished. Congratulations. Marking as verified,
Win2K, 2002022003 (it remains to see if it works on Win98 at home but I am too
glad to wait :-)).
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.