Toolbox Options has NULL title

VERIFIED FIXED in Firefox 34

Status

--
minor
VERIFIED FIXED
4 years ago
3 months ago

People

(Reporter: jjdsampson, Assigned: past, Mentored)

Tracking

unspecified
Firefox 34

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8463038 [details]
2-frame GIF toggling between Inspector and Toolbox Options in Firefox Nightly 34

User Agent: Mozilla/5.0 (Windows NT 6.4; WOW64; Trident/7.0; .NET4.0E; .NET4.0C; .NET CLR 3.5.30729; .NET CLR 2.0.50727; .NET CLR 3.0.30729; InfoPath.3; rv:11.0) like Gecko

Steps to reproduce:

1. Right click anywhere and Inspect Element.
2. With Developer Tools opened, click into Toolbox Options.


Actual results:

Title of Developer Tools window changed from "Inspector - <url>" to "(null) - <url>".


Expected results:

Title of Developer Tools window [should] change from "Inspector - <url>" to "Options - <url>".

Updated

4 years ago
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Untriaged → Developer Tools
Ever confirmed: true
OS: Windows NT → All
Hardware: x86_64 → All
Created attachment 8463394 [details] [diff] [review]
Fix the devtools window title when the options tab is selected

I decided to not special-case the options panel any further, but add an iconOnly property to the tool definitions that can be used to omit the tool's label from the tab.
Attachment #8463394 - Flags: review?(jwalker)
Assignee: nobody → past
Status: NEW → ASSIGNED
Attachment #8463394 - Flags: review?(jwalker) → review+
https://hg.mozilla.org/mozilla-central/rev/227521be1def
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 34
Mentor: ejpbruel
Duplicate of this bug: 1047963
Verified on 34.0a1 (2014-08-07).
Status: RESOLVED → VERIFIED

Updated

3 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.