Buttons Lack Color, All Black

RESOLVED WONTFIX

Status

Thunderbird
Toolbars and Tabs
RESOLVED WONTFIX
4 years ago
4 years ago

People

(Reporter: David E. Ross, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:31.0) Gecko/20100101 Thunderbird/31.0
Default Thunderbird Theme 31.0

Tool bar buttons are black, lacking any color.  With Windows XP, the tool bar buttons show color.  For example: the X for Delete is red, the flame for Junk is orange, and the bent arrows for Reply and Forward are each a distinctive color.  With Windows 7, all the buttons are black.  

The workaround for this problem is to run Thunderbird in Windows XP compatibility mode.  This is NOT a solution, only a stopgap measure.  A Windows 7 installation that otherwise functions appropriately should not have to be run in the mode of an obsolete operating system in order to get all features.  

Note that this bug replaces the part of bug #1030847 that is not a duplicate of bug #608596.  The latter only addresses the sizes of buttons.
Firefox is using on all platforms monochrome icons. We aren't planning to revert to colored icons on Win7/8 now. If this will happen, we can open then a bug for this.

In the mean time you can use 3rd party themes with colored icons.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

4 years ago
Citing a Firefox design decision is not valid for marking a Thunderbird bug report as WontFix.  Furthermore, colored buttons do indeed exist for Thunderbird 31.0 with its Default Theme 31.0 as shown when running under Windows XP compatibility mode.  Thus, the Firefox design decision has not propagated to Thunderbird.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
The FX decision was to show we are in par with them.

For you, we are not only citing a FX decision: I as TB theme owner saying this will be now WONTFIX.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.