If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Debug/XPtoolkit/Tri-state checkbox menu causes crash

RESOLVED WONTFIX

Status

()

Core
XUL
P3
normal
RESOLVED WONTFIX
18 years ago
8 months ago

People

(Reporter: jim_nance, Assigned: Peter Trudelle)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using a tree pulled on the night of July 23 and built under
Red Hat Linux 6.0, I get a reproducable crash when I select
the Debug/XPtoolkit/Tri-state checkbox menu from the main
toolbar.  The stack trace is shown below:

#0  0x408b65c8 in main_arena () from /lib/libc.so.6
#1  0x402b07ca in nsDocumentBindInfo::OnStopRequest (this=0x8488410,
    aURL=0x847da10, aStatus=2152398849, aMsg=0xbfffe430)
    at /home/jlnance/src/19980429/mozilla/webshell/src/nsDocLoader.cpp:2172
#2  0x4012656c in bam_exit_routine (URL_s=0x84db300, status=-215,
    window_id=0x84db478)
    at /home/jlnance/src/19980429/mozilla/network/module/nsNetService.cpp:1454
#3  0x400f7f9a in net_CallExitRoutine (
    exit_routine=0x4012645c <bam_exit_routine(URL_Struct_ *, int, MWContext_
*)>, URL_s=0x84db300, status=-215, format_out=38, window_id=0x84db478)
    at /home/jlnance/src/19980429/mozilla/network/main/mkgeturl.c:1142
#4  0x400fadca in NET_GetURL (URL_s=0x84db300, output_format=102,
    window_id=0x84db478,
    exit_routine=0x4012645c <bam_exit_routine(URL_Struct_ *, int, MWContext_
*)>) at /home/jlnance/src/19980429/mozilla/network/main/mkgeturl.c:3118
#5  0x401248f9 in nsNetlibService::OpenStream (this=0x80de600, aUrl=0x847da10,
    aConsumer=0x8488410)
    at /home/jlnance/src/19980429/mozilla/network/module/nsNetService.cpp:513
#6  0x402b000e in nsDocumentBindInfo::Bind (this=0x8488410, aURL=0x847da10,
    aListener=0x81334e4)
    at /home/jlnance/src/19980429/mozilla/webshell/src/nsDocLoader.cpp:1645
#7  0x402aedbf in nsDocLoaderImpl::OpenStream (this=0x836f7f0, aUrl=0x847da10,
    aConsumer=0x81334e4)
(Reporter)

Comment 1

18 years ago
This problem does not happen if --enable-nekco is used.
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
(Assignee)

Comment 2

18 years ago
resolving as wontfix, since Necko is in for good, and I can not reproduce the
crash with it.

Comment 3

18 years ago
Adding crash keyword
Keywords: crash
You need to log in before you can comment on or make changes to this bug.