[FxOS] No dolphin build was generated from 7/24

RESOLVED FIXED

Status

Firefox OS
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: whsu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
After I check the PVT server, I found that no dolphin build was generated from 7/24.
Please help us check if build server/script still work as normal.
Thanks.

Dolphin build location:
@ ENG Build:
  - https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g30_v1_4-dolphin-eng/2014/07/
@ USR Build:
  - https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-b2g30_v1_4-dolphin/2014/07/
This blocks our tests. Please help~
tl;dr: the upstream code changed and a has a bug. We should ask Spreadtrum to fix it.

Longer:
You can look at https://tbpl.mozilla.org/?tree=Mozilla-B2g30-v1.4&jobname=dolphin to figure this out. IThe dolphin builds worked on Jul 23 on rev 2d16ba0b45bc, but failed on Jul 24 on 6247843f09f1.

The compile error is
00:58:51    ERROR -  /builds/slave/b2g_m-b30_14_dolphin_ntly-0000/build/kernel/drivers/net/wireless/ittiam/wifi_nvm.c:268:5: error: 'else' without a previous 'if'
00:58:51    ERROR -  make[6]: *** [drivers/net/wireless/ittiam/wifi_nvm.o] Error 1

The changes are 
 http://hg.mozilla.org/releases/mozilla-b2g30_v1_4/pushloghtml?fromchange=2d16ba0b45bc&tochange=6247843f09f1
ie three changes to the manifest, so this looks like fallout from the change in the kernel code
 http://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/4cb6deab44ce

Specifically,
http://git.mozilla.org/?p=external/sprd-aosp/kernel/common.git;a=blobdiff;f=drivers/net/wireless/ittiam/wifi_nvm.c;h=f4bb2581c5b0b978b2038ad634b413bcc56d6a42;hp=4f43d6e9faf7c2089bf750eb468f0ed786af899d;hb=8cd7770dd67b97ffc7cf15bf0b6878b476682fbe;hpb=3d0ae166b8b22eda4342c6f06f562d7a12d689f7
Component: Releases → General
Product: Release Engineering → Firefox OS
QA Contact: rail
james, please help. This blocks our test.
Flags: needinfo?(james.zhang)
Please repo sync and rebuild, thanks.
Flags: needinfo?(james.zhang)
(In reply to Nick Thomas [:nthomas] from comment #2)
> tl;dr: the upstream code changed and a has a bug. We should ask Spreadtrum
> to fix it.
> 
> Longer:
> You can look at
> https://tbpl.mozilla.org/?tree=Mozilla-B2g30-v1.4&jobname=dolphin to figure
> this out. IThe dolphin builds worked on Jul 23 on rev 2d16ba0b45bc, but
> failed on Jul 24 on 6247843f09f1.
> 
> The compile error is
> 00:58:51    ERROR - 
> /builds/slave/b2g_m-b30_14_dolphin_ntly-0000/build/kernel/drivers/net/
> wireless/ittiam/wifi_nvm.c:268:5: error: 'else' without a previous 'if'
> 00:58:51    ERROR -  make[6]: *** [drivers/net/wireless/ittiam/wifi_nvm.o]
> Error 1
> 
> The changes are 
>  http://hg.mozilla.org/releases/mozilla-b2g30_v1_4/
> pushloghtml?fromchange=2d16ba0b45bc&tochange=6247843f09f1
> ie three changes to the manifest, so this looks like fallout from the change
> in the kernel code
>  http://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/4cb6deab44ce
> 
> Specifically,
> http://git.mozilla.org/?p=external/sprd-aosp/kernel/common.git;a=blobdiff;
> f=drivers/net/wireless/ittiam/wifi_nvm.c;
> h=f4bb2581c5b0b978b2038ad634b413bcc56d6a42;
> hp=4f43d6e9faf7c2089bf750eb468f0ed786af899d;
> hb=8cd7770dd67b97ffc7cf15bf0b6878b476682fbe;
> hpb=3d0ae166b8b22eda4342c6f06f562d7a12d689f7

Nick, according to partner, we need to sync repo and rebuild to solve this problem. Could you or anyone else could help?
Ah, fixed by eed982a4aa28fb823f1177b374544fb5b45adab3 but our tree was closed, so that change couldn't land. Reopened now.
I forced some nightly builds too, since it's quite a while until they would run automatically (midnight & 1600 Pacific), see 
  https://tbpl.mozilla.org/?tree=Mozilla-B2g30-v1.4&jobname=dolphin&rev=ff674d2bc3cf
Bug 1043735 was tracking this bustage. Would be nice if it was more obvious who to be screaming at in such situations.
Duplicate of this bug: 1043735
I went ahead and reverted the b2g-manifest change from the other previously-filed bug as well.
https://github.com/mozilla-b2g/b2g-manifest/commit/fe6da7f282fc38f4de045fcb66cca045498580e9
I'll consult with sheriffs more closely next time, and check for existing bugs. I think your b2g-manifest pin didn't work because the failure was in kernel/drivers/net/wireless/ittiam/wifi_nvm.c, rather than the open-source repo.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
ryan, you can ni on me or ryang@mozilla.com if you saw such problem caused by sprd change again. We can help push them to fix.

Nick, thank you very much for your quick action. I saw new builds comes now :D
(In reply to Peipei Cheng from comment #12)
> ryan, you can ni on me or ryang@mozilla.com if you saw such problem caused
> by sprd change again. We can help push them to fix.

Thanks, I'll try to remember that for next time :)
Nick, could you please help again? I found that the new pvt build include old commit. The gecko commit is on July 13th. But we have a lot of changes in past two weeks.

I filed bug 1045453 to follow up.


Gaia      eb3b185325901d4c04e2d43eb58d90835213bea9
Gecko     https://hg.mozilla.org/releases/mozilla-b2g30_v1_4/rev/8c8883bb5797
BuildID   20140728160206
Version   30.0
ro.build.version.incremental=314
ro.build.date=Tue Jul 22 20:54:56 CST 2014
You need to log in before you can comment on or make changes to this bug.