Closed Bug 1044985 Opened 5 years ago Closed 5 months ago

Intermittent browser_dbg_clean-exit.js | Test timed out

Categories

(DevTools :: Debugger, defect, P3)

x86
macOS
defect

Tracking

(firefox35 disabled, firefox36 disabled)

RESOLVED FIXED
Tracking Status
firefox35 --- disabled
firefox36 --- disabled

People

(Reporter: cbook, Unassigned)

References

(Blocks 1 open bug, )

Details

(Keywords: intermittent-failure, Whiteboard: [test disabled][leave open])

Attachments

(1 file)

Rev4 MacOSX Snow Leopard 10.6 b2g-inbound opt test mochitest-devtools-chrome on 2014-07-28 01:44:18 PDT for push c7c37390b46b

slave: t-snow-r4-0073

https://tbpl.mozilla.org/php/getParsedLog.php?id=44698035&tree=B2g-Inbound



3417 INFO TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_clean-exit.js | Test timed out - Test timed out
Summary: Intermittent browser_dbg_clean-exit.js | Test timed out - Test timed out → Intermittent browser_dbg_clean-exit.js | Test timed out
All the recent occurrences appear to be DevEdition-related timingwise.
Flags: needinfo?(past)
I can't think of anything dev-edition-related that could affect this test. I know that some debugger test fixes landed recently, so maybe Eddy has a clue?
Flags: needinfo?(past) → needinfo?(ejpbruel)
(In reply to Panos Astithas [:past] (overloaded, please needinfo) from comment #119)
> I can't think of anything dev-edition-related that could affect this test. I
> know that some debugger test fixes landed recently, so maybe Eddy has a clue?

I've been fixing the frontend tests for e10s, but I haven't landed my changes to this test yet.

Note that browser_dbg_clean-exit-window.js has been disabled because its a leaky test. I think this test is related to that one, so perhaps it has similar problems?
Flags: needinfo?(ejpbruel)
No, the clean-exit-window test suffers from a race in platform code that is documented in bug 933950. This is a very different race that occurs while the test is running, not on teardown.
Recent trunk-as-aurora Try pushes indicate that this will be basically perma-fail when Gecko 36 moves to Aurora in a couple weeks. In addition to the already-high frequency we're seeing this on Aurora since Gum merged over. We need a fix or disabling ASAP.
Flags: needinfo?(ejpbruel)
Figuring out which of the commits on the 8th caused this would be a big help. I'll try to do that this week, but it seems like disabling is the best option right now.
(In reply to Panos Astithas [:past] (overloaded, please needinfo) from comment #149)
> Figuring out which of the commits on the 8th caused this would be a big
> help. I'll try to do that this week, but it seems like disabling is the best
> option right now.

If you disable the test, I can spend some time bisecting tomorrow, and perhaps come up with a fix. How does that sound?
Flags: needinfo?(ejpbruel)
Attached patch patchSplinter Review
Approval Request Comment
[Feature/regressing bug #]:1044985
[User impact if declined]:permaorange
[Describe test coverage new/current, TBPL]:disabled 1 test
[Risks and why]:none
[String/UUID change made/needed]:none
Attachment #8519943 - Flags: approval-mozilla-aurora?
Comment on attachment 8519943 [details] [diff] [review]
patch

Test-only changes don't need approval. I'll land this on inbound/aurora soon.
Attachment #8519943 - Flags: approval-mozilla-aurora?
Got it. I'm trying to land this on fx-team atm, but I can't seem to push. Server problems?
https://hg.mozilla.org/releases/mozilla-aurora/rev/04d21ca90ad5
Assignee: nobody → ejpbruel
Whiteboard: [test disabled][leave open]
I tried to bisect the failing test, but I can't reproduce the failure on OSX, and I don't have access to a Windows 7 machine. Would someone else be willing to take this on?
Blocks: dbg-test
Assignee: ejpbruel → nobody
Bulk assigning P3 to all open intermittent bugs without a priority set in Firefox components per bug 1298978.
Priority: -- → P3
Product: Firefox → DevTools
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Assignee: nobody → ejpbruel
Assignee: ejpbruel → nobody
You need to log in before you can comment on or make changes to this bug.