back button fails to restore vertical scroll position

VERIFIED DUPLICATE of bug 59774

Status

--
minor
VERIFIED DUPLICATE of bug 59774
17 years ago
14 years ago

People

(Reporter: tascidblue, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.4) Gecko/20010913
BuildID:    2001091303

In the page at http://www.gnu.org/manual/bash/html_mono/bashref.html, go to the
bottom of the page and click on the link for "word splitting". Once it takes you
to that link hit the "back" button. You will be taken back to the previous page,
but the vertical scroll bar will be all the way at the top of the page. I
believe the correct behavior should place the vertical scroll bar at the bottom
of the page where the original link was.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.gnu.org/manual/bash/html_mono/bashref.html
2. Scroll to the bottom of the page.
3. On the bottom of the page is a link called "word splitting". Click on it.
4. You should be taken to the link.
5. Click on the back button in the browser.
6. Thus the bug- The browser will return to the top of the page and not to the
bottom.


Actual Results:  After hitting the back button, mozilla went to the top of the
previous page.

Expected Results:  I expected mozilla to take me to the bottom of the page (when
I hit the back button) because that is where I originally was at when I clicked
the  link called "word splitting".

For comparison Internet Explorder 5 in Windows 2000 works just as I have stated
in the above "expected results" section.
dupe of bug 59774
(scroll position not remembered if URL contains named anchor)

*** This bug has been marked as a duplicate of 59774 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
VERIFIEd Dupe
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.